summary refs log tree commit diff
path: root/gnu/packages/icu4c.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/icu4c.scm')
-rw-r--r--gnu/packages/icu4c.scm68
1 files changed, 37 insertions, 31 deletions
diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index 512967a305..922dfbd348 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -31,10 +31,32 @@
   #:use-module (guix build-system ant)
   #:use-module (guix build-system gnu))
 
+;; These patches are taken from ICUs 'maint-64' branch and will be included in
+;; 64.3.  The latter patch is needed because many packages use "invalid"
+;; locales which misbehave with ICU 64.2.  See discussion at
+;; <https://lists.gnu.org/archive/html/guix-devel/2019-07/msg00343.html>.
+(define %icu4c-patches
+  (list (origin
+          (method url-fetch)
+          (uri (string-append "https://github.com/unicode-org/icu/commit/"
+                              "7788f04eb9be0d7ecade6af46cf7b9825447763d.patch"))
+          (file-name "icu4c-datetime-regression.patch")
+          (sha256
+           (base32
+            "0gs2sbdfpzwwdjqcqr0c16fw3g7wy3gb1gbgvzs9k1ciw0bhpv4w")))
+        (origin
+          (method url-fetch)
+          (uri (string-append "https://github.com/unicode-org/icu/commit/"
+                              "cfb20862909ff105d4f2c43923c97561bc5a5815.patch"))
+          (file-name "icu4c-locale-mapping.patch")
+          (sha256
+           (base32
+            "0s5psb60aisj6icziblvlp9dqcz56n3887i8ib0yidbjnnrw5b97")))))
+
 (define-public icu4c
   (package
    (name "icu4c")
-   (version "63.1")
+   (version "64.2")
    (source (origin
             (method url-fetch)
             (uri (string-append
@@ -43,30 +65,30 @@
                   "/icu4c-"
                   (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
                   "-src.tgz"))
+            (patches %icu4c-patches)
+            (patch-flags '("-p2"))
             (sha256
-             (base32 "17fbk0lm2clsxbmjzvyp245ayx0n4chji3ky1f3fbz2ljjv91i05"))))
+             (base32 "0v0xsf14xwlj125y9fd8lrhsaych4d8liv8gr746zng6g225szb2"))))
    (build-system gnu-build-system)
+   (native-inputs
+    `(("python" ,python-minimal)))
    (inputs
     `(("perl" ,perl)))
    (arguments
     `(#:configure-flags
-      '("--enable-rpath"
-        ,@(if (let ((s (or (%current-target-system)
-                           (%current-system))))
-                (or (string-prefix? "arm" s)
-                    (string-prefix? "mips" s)))
-              '("--with-data-packaging=archive")
-              '()))
-        ,@(if (string-prefix? "i686" (or (%current-target-system)
-                                         (%current-system)))
-              ;; FIXME: Some tests are failing on i686:
-              ;; <https://unicode-org.atlassian.net/browse/ICU-20080>.
-              '(#:tests? #f)
-              '())
+      '("--enable-rpath")
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'chdir-to-source
           (lambda _ (chdir "source") #t))
+        (add-after 'chdir-to-source 'update-LDFLAGS
+          (lambda _
+            ;; Do not create a "data-only" libicudata.so because it causes
+            ;; problems on some architectures (notably armhf and MIPS).
+            (substitute* "config/mh-linux"
+              (("LDFLAGSICUDT=-nodefaultlibs -nostdlib")
+               "LDFLAGSICUDT="))
+            #t))
         (add-after 'install 'avoid-coreutils-reference
           ;; Don't keep a reference to the build tools.
           (lambda* (#:key outputs #:allow-other-keys)
@@ -83,22 +105,6 @@ C/C++ part.")
    (license x11)
    (home-page "http://site.icu-project.org/")))
 
-(define-public icu4c-64
-  (package
-    (inherit icu4c)
-    (version "64.2")
-    (source (origin
-              (inherit (package-source icu4c))
-              (uri (string-append
-                    "http://download.icu-project.org/files/icu4c/" version "/icu4c-"
-                    (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
-                    "-src.tgz"))
-              (sha256
-               (base32 "0v0xsf14xwlj125y9fd8lrhsaych4d8liv8gr746zng6g225szb2"))))
-    (native-inputs
-     `(;; For tests.
-       ("python" ,python)))))
-
 (define-public java-icu4j
   (package
     (name "java-icu4j")