summary refs log tree commit diff
path: root/gnu/packages/idutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/idutils.scm')
-rw-r--r--gnu/packages/idutils.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/idutils.scm b/gnu/packages/idutils.scm
index 26472c6900..6d2f003734 100644
--- a/gnu/packages/idutils.scm
+++ b/gnu/packages/idutils.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2015, 2021 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -36,7 +36,6 @@
              (sha256
               (base32
                "1hmai3422iaqnp34kkzxdnywl7n7pvlxp11vrw66ybxn9wxg90c1"))
-             (patches (search-patches "diffutils-gets-undeclared.patch"))
              (modules '((guix build utils)))
              (snippet
               '(begin
@@ -49,8 +48,15 @@
                                    "# define _IO_IN_BACKUP 0x100\n"
                                    "#endif\n\n"
                                    "/* BSD stdio derived implementations")))
-                 #t))))
+
+                 ;; 'gets' is deprecated in glibc 2.33 and its declaration is
+                 ;; no longer visible by default from <stdio.h>.
+                 (substitute* "lib/stdio.in.h"
+                   (("_GL_WARN_ON_USE \\(gets.*") ""))))))
     (build-system gnu-build-system)
+    (arguments
+     ;; XXX: These Gnulib tests fail with GCC 10 and glibc 2.33; skip them.
+     '(#:make-flags '("XFAIL_TESTS=test-sprintf-posix test-isnanl-nolibm")))
     (native-inputs `(("emacs" ,emacs-minimal)))
     (home-page "https://www.gnu.org/software/idutils/")
     (synopsis "Identifier database utilities")