summary refs log tree commit diff
path: root/gnu/packages/image-processing.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image-processing.scm')
-rw-r--r--gnu/packages/image-processing.scm102
1 files changed, 54 insertions, 48 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 9c2ec50bec..673c472a85 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
 ;;; Copyright © 2018 Lprndn <guix@lprndn.info>
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -28,6 +29,7 @@
   #:use-module (guix packages)
   #:use-module (guix utils)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
@@ -55,11 +57,13 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages protobuf)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages serialization)
   #:use-module (gnu packages video)
   #:use-module (gnu packages xiph)
   #:use-module (gnu packages xml)
-  #:use-module (gnu packages xorg))
+  #:use-module (gnu packages xorg)
+  #:use-module (ice-9 match))
 
 ;; We use the latest snapshot of this package because the latest release is
 ;; from 2011 and has known vulnerabilities that cannot easily be fixed by
@@ -210,13 +214,14 @@ integrates with various databases on GUI toolkits such as Qt and Tk.")
     (name "opencv")
     (version "3.4.3")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/opencv/opencv/archive/"
-                                  version ".zip"))
-              (file-name (string-append name "-" version ".zip"))
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/opencv/opencv")
+                     (commit version)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "0pycx1pz8lj794q32mlalyc3ijqxwsyin65r26nh4yc0p71xiirp"))
+                "06bc61r8myym4s8im10brdjfg4wxkrvsbhhl7vr1msdan2xddzi3"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -229,38 +234,44 @@ integrates with various databases on GUI toolkits such as Qt and Tk.")
                   ;; Some jars found:
                   (for-each delete-file
                             '("modules/java/test/pure_test/lib/junit-4.11.jar"
-                              "samples/java/sbt/sbt/sbt-launch.jar"))))))
+                              "samples/java/sbt/sbt/sbt-launch.jar"))
+                  #t))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags
        (list "-DWITH_IPP=OFF"
              "-DWITH_ITT=OFF"
+             "-DWITH_CAROTENE=OFF" ; only visible on arm/aarch64
+             "-DENABLE_PRECOMPILED_HEADERS=OFF"
 
              ;; CPU-Features:
              ;; See cmake/OpenCVCompilerOptimizations.cmake
              ;; (CPU_ALL_OPTIMIZATIONS) for a list of all optimizations
              ;; BASELINE is the minimum optimization all CPUs must support
              ;;
-             ;; DISPATCH is the list of optional dispatches
-             "-DCPU_BASELINE=SSE2, NEON"
+             ;; DISPATCH is the list of optional dispatches.
+             "-DCPU_BASELINE=SSE2"
 
-             "-DCPU_DISPATCH=SSE3,SSSE3,SSE4_1,SSE4_2,AVX,AVX2"
-             "-DCPU_DISPATCH_REQUIRE=SSE3,SSSE3,SSE4_1,SSE4_2,AVX,AVX2"
+             ,@(match (%current-system)
+                 ("x86_64-linux"
+                  '("-DCPU_DISPATCH=NEON;VFPV3;FP16;SSE;SSE2;SSE3;SSSE3;SSE4_1;SSE4_2;POPCNT;AVX;FP16;AVX2;FMA3;AVX_512F;AVX512_SKX"
+                    "-DCPU_DISPATCH_REQUIRE=SSE3,SSSE3,SSE4_1,SSE4_2,AVX,AVX2"))
+                 ("armhf-linux"
+                  '("-DCPU_BASELINE_DISABLE=NEON")) ; causes build failures
+                 ("aarch64-linux"
+                  '("-DCPU_BASELINE=NEON"
+                    "-DCPU_DISPATCH=NEON;VFPV3;FP16"))
+                 (_ '()))
 
              "-DBUILD_PERF_TESTS=OFF"
-             "-D BUILD_TESTS=ON"
+             "-DBUILD_TESTS=ON"
 
-             (string-append "-DOPENCV_EXTRA_MODULES_PATH="
-                            "/tmp/guix-build-opencv-" ,version ".drv-0"
-                            "/opencv-contrib/opencv_contrib-" ,version
-                            "/modules")
+             (string-append "-DOPENCV_EXTRA_MODULES_PATH=" (getcwd)
+                            "/opencv-contrib/modules")
 
              ;;Define test data:
-             (string-append "-DOPENCV_TEST_DATA_PATH="
-                            "/tmp/guix-build-opencv-" ,version ".drv-0"
-                            ;;"/opencv-3.4.0"
-                            "/opencv-extra/opencv_extra-" ,version
-                            "/testdata")
+             (string-append "-DOPENCV_TEST_DATA_PATH=" (getcwd)
+                            "/opencv-extra/testdata")
 
              ;; Is ON by default and would try to rebuild 3rd-party protobuf,
              ;; which we had removed, which would lead to an error:
@@ -293,35 +304,28 @@ integrates with various databases on GUI toolkits such as Qt and Tk.")
 
              ;; This one fails with "unknown file: Failure"
              ;; But I couldn't figure out which file was missing:
-             (substitute* (list (string-append
-                                 "../opencv-contrib/opencv_contrib-"
-                                 ,version
-                                 "/modules/face/test/test_face_align.cpp"))
+             (substitute* "../opencv-contrib/modules/face/test/test_face_align.cpp"
                (("(TEST\\(CV_Face_FacemarkKazemi, )(can_detect_landmarks\\).*)"
                  all pre post)
                 (string-append pre "DISABLED_" post)))
 
              ;; Failure reason: Bad accuracy
              ;; Incorrect count of accurate poses [2nd case]: 90.000000 / 94.000000
-             (substitute* (list (string-append
-                                 "../opencv-contrib/opencv_contrib-"
-                                 ,version
-                                 "/modules/rgbd/test/test_odometry.cpp"))
+             (substitute* "../opencv-contrib/modules/rgbd/test/test_odometry.cpp"
                (("(TEST\\(RGBD_Odometry_Rgbd, )(algorithmic\\).*)" all pre post)
                 (string-append pre "DISABLED_" post)))
              #t))
 
-         ;; Idea copied from ldc.scm (ldc-bootstrap):
          (add-after 'unpack 'unpack-submodule-sources
            (lambda* (#:key inputs #:allow-other-keys)
              (mkdir "../opencv-extra")
              (mkdir "../opencv-contrib")
-             (let ((unpack (lambda (source target)
-                             (with-directory-excursion target
-                               (apply invoke "unzip"
-                                      (list (assoc-ref inputs source)))))))
-               (unpack "opencv-extra" "../opencv-extra")
-               (unpack "opencv-contrib" "../opencv-contrib"))))
+             (copy-recursively (assoc-ref inputs "opencv-extra")
+                               "../opencv-extra")
+             (invoke "tar" "xvf"
+                     (assoc-ref inputs "opencv-contrib")
+                     "--strip-components=1"
+                     "-C" "../opencv-contrib")))
 
          (add-after 'set-paths 'add-ilmbase-include-path
            (lambda* (#:key inputs #:allow-other-keys)
@@ -343,25 +347,27 @@ integrates with various databases on GUI toolkits such as Qt and Tk.")
              ;; Therefore we must do it.
              (zero? (system (format #f "~a/bin/Xvfb ~a &" xorg-server disp)))))))))
     (native-inputs
-     `(("unzip" ,unzip)
-       ("pkg-config" ,pkg-config)
+     `(("pkg-config" ,pkg-config)
        ("xorg-server" ,xorg-server) ; For running the tests
        ("opencv-extra"
         ,(origin
-           (method url-fetch)
-           (uri (string-append "https://codeload.github.com/"
-                               "opencv/opencv_extra/zip/" version))
-           (file-name (string-append "opencv-extra-" version ".zip"))
+           (method git-fetch)
+           (uri (git-reference
+                  (url "https://github.com/opencv/opencv_extra")
+                  (commit version)))
+           (file-name (git-file-name "opencv_extra" version))
            (sha256
-            (base32 "0yd1vidzbg6himxyh4yzivywijg8548kfmcn421khabnipm7l74y"))))
+            (base32 "08p5xnq8n1jw8svvz0fnirfg7q8dm3p4a5dl7527s5xj0f9qn7lp"))))
        ("opencv-contrib"
         ,(origin
-           (method url-fetch)
-           (uri (string-append "https://codeload.github.com/"
-                               "opencv/opencv_contrib/zip/" version))
-           (file-name (string-append "opencv-contrib-" version ".zip"))
+           (method git-fetch)
+           (uri (git-reference
+                  (url "https://github.com/opencv/opencv_contrib")
+                  (commit version)))
+           (file-name (git-file-name "opencv_contrib" version))
+           (patches (search-patches "opencv-rgbd-aarch64-test-fix.patch"))
            (sha256
-           (base32 "0j0ci6ia1qwklp9hq07ypl0vkngj1wrgh6n98n657m5d0pyp4m0g"))))))
+            (base32 "1f334glf39nk42mpqq6j732h3ql2mpz89jd4mcl678s8n73nfjh2"))))))
     (inputs `(("libjpeg" ,libjpeg)
               ("libpng" ,libpng)
               ("jasper" ,jasper)