summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm66
1 files changed, 36 insertions, 30 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index d03a0a287d..207faede91 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -501,13 +501,13 @@ collection of tools for doing simple manipulations of TIFF images.")
     (version "1.74.4")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/DanBloomberg/leptonica/archive/" version
-             ".tar.gz"))
-       (file-name (string-append "leptonica-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/DanBloomberg/leptonica.git")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "10pw7pwccd0m0fc9rlrr2m41s7j1qvba2wcrav17pw1gclkf34i0"))))
+        (base32 "0sfg1ky0lghlq7xx0qii5167bim0wwfnnr83dl4skbj9awyvjiwi"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("gnuplot" ,gnuplot)             ;needed for test suite
@@ -1102,13 +1102,14 @@ convert, manipulate, filter and display a wide variety of image formats.")
     (name "jasper")
     (version "2.0.14")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/mdadams/jasper/archive/"
-                                  "version-" version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mdadams/jasper.git")
+                    (commit (string-append "version-" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "0yx9y5y0g6jv142vnqp50j3k8k5yqznz3smrblv192wgfbm6w9l5"))))
+                "0aarg8nbik9wrm7fx0451sbm5ypfdfr6i169pxzi354mpdp8gg7f"))))
     (build-system cmake-build-system)
     (inputs `(("libjpeg" ,libjpeg)))
     (synopsis "JPEG-2000 library")
@@ -1124,13 +1125,14 @@ ISO/IEC 15444-1).")
     (version "2.5")
     (source
       (origin
-        (method url-fetch)
-        (uri (string-append "https://github.com/sekrit-twc/zimg/archive/"
-                            "release-" version ".tar.gz"))
-        (file-name (string-append name "-" version ".tar.gz"))
+        (method git-fetch)
+        (uri (git-reference
+              (url "https://github.com/sekrit-twc/zimg.git")
+              (commit (string-append "release-" version))))
+        (file-name (git-file-name name version))
         (sha256
          (base32
-          "0kbq2dy659645fmgxpzg38b6y6x82kwkydhc380kdkaikv2brcjh"))))
+          "05krggiifbl6hyg2j3z8qz2k7si84g1qg9snhsnf1ml7mrhqhhlr"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("autoconf" ,autoconf)
@@ -1374,12 +1376,14 @@ medical image data, e.g. magnetic resonance image (MRI) and functional MRI
     (name "gpick")
     (version "0.2.5")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/thezbyg/gpick/archive/"
-                                  name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/thezbyg/gpick.git")
+                    (commit (string-append name "-" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "0mxvxk15xhk2i5vfavjhnkk4j3bnii0gpf8di14rlbpq070hd5rs"))))
+                "0mcj806zagh122qgrdkrg0macpzby97y89xi2sjyn3bh8vmmyxjy"))))
     (build-system scons-build-system)
     (native-inputs
      `(("boost" ,boost)
@@ -1435,13 +1439,14 @@ parsing, viewing, modifying, and saving this metadata.")
     (version "0.5.1")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/lupoDharkael/flameshot/archive/"
-                           "v" version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/lupoDharkael/flameshot.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "0kp451bqgssvg8n3sg60s3fifplm9l5kxiij0yxkl864p2mhw8im"))))
+         "13h77np93r796jf289v4r687cmnpqkyqs34dm9gif4akaig74ky0"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("qttools" ,qttools)))
@@ -1544,13 +1549,14 @@ identical visual appearance.")
     (version "1.0.7")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/cslarsen/jp2a/archive/v"
-                           version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/cslarsen/jp2a.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "0nahpjvrahixcfqqrjj2k4fscc8qs4hqnmj2qgjzsjj3z6xxh2g5"))
-       (file-name (string-append name "-" version ".tar.gz"))))
+         "12a1z9ba2j16y67f41y8ax5sgv1wdjd71pg7circdxkj263n78ql"))))
     (build-system gnu-build-system)
     (inputs
      `(("libjpeg" ,libjpeg)