summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm28
1 files changed, 6 insertions, 22 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 4b05cca3b4..5017a21256 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -770,31 +770,15 @@ convert, manipulate, filter and display a wide variety of image formats.")
 (define-public jasper
   (package
     (name "jasper")
-    (version "1.900.1")
+    (version "1.900.5")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://www.ece.uvic.ca/~frodo/jasper"
-                                  "/software/jasper-" version ".zip"))
+                                  "/software/jasper-" version ".tar.gz"))
               (sha256
                (base32
-                "154l7zk7yh3v8l2l6zm5s2alvd2fzkp6c9i18iajfbna5af5m43b"))
-              (patches (search-patches
-                        "jasper-CVE-2007-2721.patch"
-                        "jasper-CVE-2008-3520.patch"
-                        "jasper-CVE-2008-3522.patch"
-                        "jasper-CVE-2011-4516-and-CVE-2011-4517.patch"
-                        "jasper-CVE-2014-8137.patch"
-                        "jasper-CVE-2014-8138.patch"
-                        "jasper-CVE-2014-8157.patch"
-                        "jasper-CVE-2014-8158.patch"
-                        "jasper-CVE-2014-9029.patch"
-                        "jasper-CVE-2016-1577.patch"
-                        "jasper-CVE-2016-1867.patch"
-                        "jasper-CVE-2016-2089.patch"
-                        "jasper-CVE-2016-2116.patch"))))
+                "1fvy4ngc6064g128q4484qpinsn05y9qw6lrccc4czhalla2w26m"))))
     (build-system gnu-build-system)
-    (native-inputs
-     `(("unzip" ,unzip)))
     (synopsis "JPEG-2000 library")
     (description "The JasPer Project is an initiative to provide a reference
 implementation of the codec specified in the JPEG-2000 Part-1 standard (i.e.,
@@ -805,7 +789,7 @@ ISO/IEC 15444-1).")
 (define-public zimg
   (package
     (name "zimg")
-    (version "2.2.1")
+    (version "2.3")
     (source
       (origin
         (method url-fetch)
@@ -814,7 +798,7 @@ ISO/IEC 15444-1).")
         (file-name (string-append name "-" version ".tar.gz"))
         (sha256
          (base32
-          "0m2gjpkb0dlg4j77nr41z284zvyfq9qg3ahsv8p1xy8jfr7h1hqa"))))
+          "1yh6kkq8596a9cxcmcxzqvwbwmxwqapwsq31xpccznw6z62j75h9"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("autoconf" ,autoconf)
@@ -832,7 +816,7 @@ of scaling, colorspace conversion, and depth conversion.  A simple API enables
 conversion between any supported formats to operate with minimal knowledge from
 the programmer.")
     (home-page "https://github.com/sekrit-twc/zimg")
-    ;; test/extra/ contains musl-libm, 
+    ;; test/extra/ contains musl-libm,
     ;; which is MIT/expat licensed, but only used for tests
     (license (license:fsf-free "file://COPYING")))) ;WTFPL version 2