summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index e76661c7d4..c2aae10c87 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -68,6 +68,7 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages sphinx)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages qt)
@@ -859,7 +860,7 @@ graphics image formats like PNG, BMP, JPEG, TIFF and others.")
    (native-inputs
     `(("doxygen" ,doxygen)
       ("python2-nose" ,python2-nose)
-      ("python2-sphinx" ,python2-sphinx)))
+      ("sphinx" ,python-sphinx)))
    (arguments
     `(#:test-target "check"
       #:phases
@@ -1008,9 +1009,9 @@ channels.")
     (version "0.26")
     (source (origin
              (method url-fetch)
-             (uri (list (string-append "http://www.exiv2.org/builds/exiv2-"
+             (uri (list (string-append "https://www.exiv2.org/builds/exiv2-"
                                        version "-trunk.tar.gz")
-                        (string-append "http://www.exiv2.org/exiv2-"
+                        (string-append "https://www.exiv2.org/exiv2-"
                                        version ".tar.gz")
                         (string-append "https://fossies.org/linux/misc/exiv2-"
                                        version ".tar.gz")))
@@ -1026,7 +1027,7 @@ channels.")
        ("zlib" ,zlib)))
     (native-inputs
      `(("intltool" ,intltool)))
-    (home-page "http://www.exiv2.org/")
+    (home-page "https://www.exiv2.org/")
     (synopsis "Library and command-line utility to manage image metadata")
     (description
      "Exiv2 is a C++ library and a command line utility to manage image
@@ -1131,7 +1132,7 @@ the programmer.")
     (home-page "https://github.com/sekrit-twc/zimg")
     ;; test/extra/ contains musl-libm,
     ;; which is MIT/expat licensed, but only used for tests
-    (license (license:fsf-free "file://COPYING")))) ;WTFPL version 2
+    (license license:wtfpl2)))
 
 (define-public perceptualdiff
   (package