summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 7f4327badc..4b05cca3b4 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -570,18 +570,19 @@ supplies a generic doubly-linked list and some string functions.")
             (sha256
              (base32
               "12bz57asdcfsz3zr9i9nska0fb6h3z2aizy412qjqkixkginbz7v"))
-            (patches (search-patches "freeimage-CVE-2015-0852.patch"))))
+            (patches (search-patches "freeimage-CVE-2015-0852.patch"
+                                     "freeimage-CVE-2016-5684.patch"))))
    (build-system gnu-build-system)
    (arguments
-    '(#:phases (alist-delete
-                'configure
-                (alist-cons-before
-                 'build 'patch-makefile
-                 (lambda* (#:key outputs #:allow-other-keys)
-                   (substitute* "Makefile.gnu"
-                     (("/usr") (assoc-ref outputs "out"))
-                     (("-o root -g root") "")))
-                 %standard-phases))
+    '(#:phases
+      (modify-phases %standard-phases
+        (delete 'configure)
+        (add-before 'build 'patch-makefile
+          (lambda* (#:key outputs #:allow-other-keys)
+            (substitute* "Makefile.gnu"
+              (("/usr") (assoc-ref outputs "out"))
+              (("-o root -g root") ""))
+            #t)))
       #:make-flags '("CC=gcc")
       #:tests? #f)) ; no check target
    (native-inputs