summary refs log tree commit diff
path: root/gnu/packages/imagemagick.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/imagemagick.scm')
-rw-r--r--gnu/packages/imagemagick.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index d4edbec31d..e80da6d848 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -77,7 +77,8 @@
                         (let ((doc (assoc-ref outputs "doc")))
                           (string-append "DOCUMENTATION_PATH = "
                                          doc "/share/doc/"
-                                         ,name "-" ,version "\n"))))))
+                                         ,name "-" ,version "\n"))))
+                     #t))
                   (add-before
                    'configure 'strip-configure-xml
                    (lambda _
@@ -87,7 +88,8 @@
                        ;; include --docdir, and thus retain a reference to the
                        ;; 'doc' output.
                        (("@CONFIGURE_ARGS@")
-                        "not recorded")))))))
+                        "not recorded"))
+                     #t)))))
     ;; TODO: Add Jasper etc.
     (inputs `(("fftw" ,fftw)
               ("graphviz" ,graphviz)
@@ -144,7 +146,8 @@ text, lines, polygons, ellipses and Bézier curves.")
                 (("my \\$INC_magick = .*")
                  "my $INC_magick = `pkg-config --cflags ImageMagick`;\n")
                 (("my \\$LIBS_magick = .*")
-                 "my $LIBS_magick = `pkg-config --libs ImageMagick`;\n")))))
+                 "my $LIBS_magick = `pkg-config --libs ImageMagick`;\n"))
+              #t)))
          (add-before
           'check 'skip-mpeg-tests
           (lambda _
@@ -152,7 +155,8 @@ text, lines, polygons, ellipses and Bézier curves.")
             ;; MPEG.  Has been reported elsewhere,
             ;; http://www.imagemagick.org/discourse-server/viewtopic.php?f=7&t=25036,
             ;; so skip for now.
-            (delete-file "t/mpeg/read.t"))))))
+            (delete-file "t/mpeg/read.t")
+            #t)))))
     (home-page "http://search.cpan.org/dist/PerlMagick")
     (synopsis "Perl interface to ImageMagick")
     (description "This Perl extension allows the reading, manipulation and