summary refs log tree commit diff
path: root/gnu/packages/indent.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/indent.scm')
-rw-r--r--gnu/packages/indent.scm58
1 files changed, 0 insertions, 58 deletions
diff --git a/gnu/packages/indent.scm b/gnu/packages/indent.scm
deleted file mode 100644
index 3465d63c01..0000000000
--- a/gnu/packages/indent.scm
+++ /dev/null
@@ -1,58 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages indent)
-  #:use-module (gnu packages)
-  #:use-module ((guix licenses) #:prefix license:)
-  #:use-module (guix packages)
-  #:use-module (guix download)
-  #:use-module (guix build-system gnu))
-
-(define-public indent
-  (package
-   (name "indent")
-   (version "2.2.10")
-   (source (origin
-            (method url-fetch)
-            (uri (string-append "mirror://gnu/indent/indent-" version
-                                ".tar.gz"))
-            (sha256 (base32
-                     "0f9655vqdvfwbxvs1gpa7py8k1z71aqh8hp73f65vazwbfz436wa"))))
-   (build-system gnu-build-system)
-   (arguments
-    `(#:phases
-      (modify-phases %standard-phases
-        (add-after 'unpack 'fix-docdir
-          (lambda _
-            ;; Although indent uses a modern autoconf in which docdir
-            ;; defaults to PREFIX/share/doc, the doc/Makefile.am
-            ;; overrides this to be in PREFIX/doc.  Fix this.
-            (substitute* "doc/Makefile.in"
-              (("^docdir = .*$") "docdir = @docdir@\n"))
-            #t)))))
-   (synopsis "Code reformatter")
-   (description
-    "Indent is a program that makes source code easier to read by
-reformatting it in a consistent style.  It can change the style to one of
-several different styles such as GNU, BSD or K&R.  It has some flexibility to
-deal with incomplete or malformed syntax.  GNU indent offers several
-extensions over the standard utility.")
-   (license license:gpl3+)
-   (home-page "https://www.gnu.org/software/indent/")))