summary refs log tree commit diff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm23
1 files changed, 10 insertions, 13 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 0a6c28980d..b102619b2d 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -195,14 +195,14 @@ Conferencing} and @acronym{ICB, Internet Citizen's Band}.")
 (define-public weechat
   (package
     (name "weechat")
-    (version "3.6")
+    (version "3.8")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://weechat.org/files/src/weechat-"
                                   version ".tar.xz"))
               (sha256
                (base32
-                "1ppj676gwh67krq92xnfkmh3qnwbz8d51djsscxw013x7cdxg1cx"))))
+                "0a5zfkqqdkya111rl2gpwlbfala0305qry9cdz2r1h7q0316bjzp"))))
     (build-system cmake-build-system)
     (outputs '("out" "doc"))
     (native-inputs
@@ -210,9 +210,7 @@ Conferencing} and @acronym{ICB, Internet Citizen's Band}.")
        ("pkg-config" ,pkg-config)
        ,@(if (target-x86?)
            `(("ruby-asciidoctor" ,ruby-asciidoctor))
-           '())
-       ;; For tests.
-       ("cpputest" ,cpputest)))
+           '())))
     (inputs
      (list aspell
            curl
@@ -234,8 +232,7 @@ Conferencing} and @acronym{ICB, Internet Citizen's Band}.")
              ,@(if (target-x86?)
                  '("-DENABLE_MAN=ON"
                    "-DENABLE_DOC=ON")
-                '())
-             "-DENABLE_TESTS=ON")       ; ‘make test’ fails otherwise
+                '()))
        #:phases
        (modify-phases %standard-phases
          ,@(if (target-x86?)
@@ -346,14 +343,14 @@ for the IRCv3 protocol.")
 (define-public catgirl
   (package
     (name "catgirl")
-    (version "1.9a")
+    (version "2.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://git.causal.agency/catgirl/snapshot/"
                                   name "-" version ".tar.gz"))
               (sha256
                (base32
-                "0pci8crcgm33zb58y7ky2aydzyqsirj8ri8ik1zdlz6npadbjj9h"))))
+                "13pfphcfkdzqfb4x7w21xp6rnmg3ix9f39mpqmxxzg15ys1gp2x6"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f ; no tests
@@ -438,7 +435,7 @@ highlighted.
 (define-public kirc
   (package
     (name "kirc")
-    (version "0.2.9")
+    (version "0.3.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -446,7 +443,7 @@ highlighted.
                      (commit version)))
               (file-name (git-file-name name version))
               (sha256
-               (base32 "0ahmfxhgcvnlgmxxbv9vga5x6krab1n7qq55ygj7hj3x7s7ra419"))))
+               (base32 "1ighpinss3k6xyqk05wrs76wvp2ahhh0jkkg8h7bhg66b14fsws9"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ; no tests
@@ -590,14 +587,14 @@ interface for those who are accustomed to the ircII way of doing things.")
 (define-public litterbox
   (package
     (name "litterbox")
-    (version "1.8")
+    (version "1.9")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://git.causal.agency/litterbox/snapshot/litterbox-"
                            version ".tar.gz"))
        (sha256
-        (base32 "0ll5d18slngdg2qhaxkvrcq2p1admh0h7sr06wx8347ka0vvrgjl"))))
+        (base32 "1ag5x7h71pxjaaf4b561rwdqr05zzywkc0p3jf2yhg3lbjkjrc7z"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f ; There are no tests.