summary refs log tree commit diff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm53
1 files changed, 21 insertions, 32 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index aa80fa8cf9..c914ccc18e 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -861,21 +861,17 @@ new Date();"))
     (name "openjdk")
     (version "9.181")
     (source (origin
-              (method url-fetch)
-              (uri "https://hg.openjdk.java.net/jdk/jdk/archive/3cc80be736f2.tar.bz2")
-              (file-name (string-append name "-" version ".tar.bz2"))
+              (method hg-fetch)
+              (uri (hg-reference (url "https://hg.openjdk.org/jdk/jdk")
+                                 (changeset "jdk-9+181")))
+              (file-name (hg-file-name name version))
+              (modules '((guix build utils)))
+              (snippet `(begin
+                          (for-each delete-file
+                                    (find-files "." ".*.(bin|exe|jar)$"))))
               (sha256
                (base32
-                "01ihmyf7k5z17wbr7xig7y40l9f01d5zjgkcmawn1102hw5kchpq"))
-              (patches (search-patches
-                        "openjdk-9-hotspot-pointer-comparison.patch"
-                        "openjdk-9-hotspot-stack-size.patch"))
-              (modules '((guix build utils)))
-              (snippet
-               `(begin
-                  (for-each delete-file
-                            (find-files "." ".*.(bin|exe|jar)$"))
-                  #t))))
+                "1v92nzdqx07c35x945awzir4yk0fk22vky6fpp8mq9js930sxsz0"))))
     (build-system gnu-build-system)
     (outputs '("out" "jdk" "doc"))
     (arguments
@@ -1036,7 +1032,7 @@ new Date();"))
        ("unzip" ,unzip)
        ("which" ,which)
        ("zip" ,zip)))
-    (home-page "https://openjdk.java.net/projects/jdk9/")
+    (home-page "https://openjdk.org/projects/jdk9/")
     (synopsis "Java development kit")
     (description
      "This package provides the Java development kit OpenJDK.")
@@ -1048,19 +1044,17 @@ new Date();"))
     (name "openjdk")
     (version "10.46")
     (source (origin
-              (method url-fetch)
-              (uri "http://hg.openjdk.java.net/jdk/jdk/archive/6fa770f9f8ab.tar.bz2")
-              (file-name (string-append name "-" version ".tar.bz2"))
+              (method hg-fetch)
+              (uri (hg-reference (url "https://hg.openjdk.org/jdk/jdk")
+                                 (changeset "jdk-10+46")))
+              (file-name (hg-file-name name version))
+              (modules '((guix build utils)))
+              (snippet `(begin
+                          (for-each delete-file
+                                    (find-files "." ".*.(bin|exe|jar)$"))))
               (sha256
                (base32
-                "0zywq2203b4hx4jms9vbwvjcj1d3k2v3qpx4s33729fkpmid97r4"))
-              (patches (search-patches
-                        "openjdk-10-idlj-reproducibility.patch"
-                        "openjdk-10-hotspot-pointer-comparison.patch"
-                        "openjdk-10-hotspot-stack-size.patch"))
-              (modules '((guix build utils)))
-              (snippet
-               '(for-each delete-file (find-files "." "\\.(bin|exe|jar)$")))))
+                "0i47ar8lxzjrkkiwbzybfxs473390h4jq9ahm3xqdvy5zpchxy3y"))))
     (arguments
      (substitute-keyword-arguments (package-arguments openjdk9)
        ((#:phases phases)
@@ -1432,8 +1426,7 @@ new Date();"))
         "0mbhdrk12b6878kby0flnbak7444dlpm0ihlmf92vk59y1c02bc2"))
       (modules '((guix build utils)))
       (snippet
-       '(for-each delete-file (find-files "." "\\.(bin|exe|jar)$")))
-      (patches (search-patches "openjdk-10-hotspot-stack-size.patch"))))
+       '(for-each delete-file (find-files "." "\\.(bin|exe|jar)$")))))
    (arguments
     (substitute-keyword-arguments (package-arguments openjdk11)
       ((#:phases phases)
@@ -1460,8 +1453,6 @@ blacklisted.certs.pem"
    "07k9bsbxwyf2z2n50z96nvhsdai916mxdxcr5lm44jz7f6xrwfq6"
    (source (origin
              (inherit (package-source base))
-             (patches
-              (search-patches "openjdk-10-hotspot-stack-size.patch"))
              (snippet                   ;override snippet
               '(begin
                  ;; The m4 macro uses 'help' to search for builtins, which is
@@ -1493,9 +1484,7 @@ blacklisted.certs.pem"
   (make-openjdk openjdk15 "16.0.2"
                 "0587px2qbz07g3xi4a3ya6m630p72dvkxcn0bj1813pxnwvcgigz"
    (source (origin
-             (inherit (package-source base))
-             (patches
-              (search-patches "openjdk-10-hotspot-stack-size.patch"))))))
+             (inherit (package-source base))))))
 
 (define-public openjdk17
   (make-openjdk