summary refs log tree commit diff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm42
1 files changed, 40 insertions, 2 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 7b0507d93c..14fef6986c 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -7908,6 +7908,40 @@ Commons CLI supports different types of options:
 This is a part of the Apache Commons Project.")
     (license license:asl2.0)))
 
+(define-public java-commons-text
+  (package
+    (name "java-commons-text")
+    (version "1.9")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://apache/commons/text/source/"
+                                  "commons-text-" version "-src.tar.gz"))
+              (sha256
+               (base32
+                "1k99ib2dxlqxb5y94kpzf4ix8xgxz1j3n9kq3ddssqqcccsp5ik2"))))
+    (build-system ant-build-system)
+    (arguments
+     (list #:jar-name "java-commons-text.jar"
+           #:source-dir "src/main/java"
+           #:test-dir "src/test"
+           #:tests? #f                  ; Tests require JUnit5.
+           #:phases
+           #~(modify-phases %standard-phases
+               (replace 'install
+                 (install-from-pom "pom.xml")))))
+    (inputs
+     (list java-commons-io))
+    (propagated-inputs
+     (list java-commons-lang3
+           apache-commons-parent-pom-51))
+    (home-page "https://commons.apache.org/text/")
+    (synopsis "Library focused on algorithms working on strings")
+    (description "Apache Commons Text is a library focused on algorithms
+working on strings.
+
+This is a part of the Apache Commons Project.")
+    (license license:asl2.0)))
+
 (define-public java-commons-codec
   (package
     (name "java-commons-codec")
@@ -13677,7 +13711,7 @@ network protocols, and core version control algorithms.")
 (define-public abcl
   (package
     (name "abcl")
-    (version "1.8.0")
+    (version "1.9.0")
     (source
      (origin
        (method url-fetch)
@@ -13685,7 +13719,7 @@ network protocols, and core version control algorithms.")
                            version "/abcl-src-" version ".tar.gz"))
        (sha256
         (base32
-         "0zr5mmqyj484vza089l8vc88d07g0m8ymxzglvar3ydwyvi1x1qx"))
+         "0scqq5c7201xhp0g6i4y3m2nrk6l5any1nisiscbsd48ya25qax1"))
        (patches
         (search-patches
          "abcl-fix-build-xml.patch"))))
@@ -13732,6 +13766,10 @@ Lisp language featuring both an interpreter and a compiler, running in the
 JVM.  It supports JSR-223 (Java scripting API): it can be a scripting engine
 in any Java application.  Additionally, it can be used to implement (parts of)
 the application using Java to Lisp integration APIs.")
+    (native-search-paths
+     (list (search-path-specification
+            (variable "XDG_DATA_DIRS")
+            (files '("share")))))
     (license (list license:gpl2+
                    ;; named-readtables is released under 3 clause BSD
                    license:bsd-3