summary refs log tree commit diff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index d50281839f..db730cd60e 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -160,6 +160,11 @@ build process and its dependencies, whereas Make uses Makefile format.")
        ;;   made no attempts to make a list of failing JDK tests.  At least
        ;;   222 tests are failing of which at least 132 are AWT tests.
        #:tests? #f
+
+       ;; The DSOs use $ORIGIN to refer to each other, but (guix build
+       ;; gremlin) doesn't support it yet, so skip this phase.
+       #:validate-runpath? #f
+
        #:configure-flags
        (let* ((gcjdir (assoc-ref %build-inputs "gcj"))
               (ecj    (string-append gcjdir "/share/java/ecj.jar"))