summary refs log tree commit diff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm18
1 files changed, 12 insertions, 6 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 6c7e5f9b15..171f55673d 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -7955,14 +7955,14 @@ This is a part of the Apache Commons Project.")
 (define-public java-commons-codec
   (package
     (name "java-commons-codec")
-    (version "1.14")
+    (version "1.15")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://apache/commons/codec/source/"
                                   "commons-codec-" version "-src.tar.gz"))
               (sha256
                (base32
-                "11xr0agckkhm91pb5akf2mbk84yd54gyr178wj57gsm97fi7nkh9"))))
+                "01z9qmg8fd8d7p7xxipwj1vi9bmvpgqyi29kldjz2x6vzwm171jj"))))
     (build-system ant-build-system)
     (arguments
      `(#:jar-name "java-commons-codec.jar"
@@ -7974,13 +7974,19 @@ This is a part of the Apache Commons Project.")
          (add-before 'build 'copy-resources
            (lambda _
              (copy-recursively "src/main/resources"
-                               "build/classes")
-             #t))
+                               "build/classes")))
          (add-before 'check 'copy-test-resources
            (lambda _
              (copy-recursively "src/test/resources"
-                               "build/test-classes")
-             #t))
+                               "build/test-classes")))
+         (add-before 'check 'skip-ravenous-test
+           (lambda _
+             ;; This test admits to being "memory hungry", but reliably fails
+             ;; even on a machine that should have plenty (12 GiB).  Skip it.
+             (substitute*
+                 "src/test/java/org/apache/commons/codec/binary/BaseNCodecTest.java"
+               (("\\bassertEnsureBufferSizeExpandsToMaxBufferSize.*;")
+                "return;"))))
          (replace 'install (install-from-pom "pom.xml")))))
     (native-inputs
      `(("java-commons-lang3" ,java-commons-lang3)