summary refs log tree commit diff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm92
1 files changed, 77 insertions, 15 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 414aba03f0..b6da796b59 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1,9 +1,10 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2020, 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
 ;;; Copyright © 2021, 2022 Simon Tournier <zimon.toutoune@gmail.com>
-;;; Copyright © 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2021-2023 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -746,6 +747,36 @@ variables, both with unordered (nominal variables) and ordered categories
     (description "This package provides a C-compatible enum for Julia.")
     (license license:expat)))
 
+(define-public julia-cfitsio
+  (package
+    (name "julia-cfitsio")
+    (version "1.4.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaAstro/CFITSIO.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "05bxzzjcc021p3hi092h06r2q7qnvql0xz1alggi83i0pp1mxp6d"))))
+    (build-system julia-build-system)
+    (native-inputs (list julia-aqua))
+    (propagated-inputs (list julia-cfitsio-jll))
+    (home-page "https://github.com/JuliaAstro/CFITSIO.jl")
+    (synopsis "C-style interface to the libcfitsio library")
+    (description "This package provides Julia implementation of C-style
+interface to CFITSIO functions with following features:
+@itemize
+@item Function names closely mirror the C interface (e.g.,
+@code{fits_open_file()}).
+@item Functions operate on @code{FITSFile}, a thin wrapper for fitsfile C
+struct (@code{FITSFile} has concept of \"current HDU\", as in CFITSIO).
+@item Wrapper functions do check the return status from CFITSIO and throw an
+error with the appropriate message.
+@end itemize")
+    (license license:expat)))
+
 (define-public julia-chainrules
   (package
     (name "julia-chainrules")
@@ -1202,7 +1233,7 @@ as SLAM (simultaneous localization and mapping).")
 (define-public julia-crayons
   (package
     (name "julia-crayons")
-    (version "4.0.4")
+    (version "4.1.1")
     (source
       (origin
         (method git-fetch)
@@ -1211,7 +1242,7 @@ as SLAM (simultaneous localization and mapping).")
                (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "0v3zhjlnb2914bxcj4myl8pgb7m31p77aj2k1bckmqs96jdph10z"))))
+         (base32 "0vfbb02pclwlbpcl7rhr98a495kga5wydf5wz1gp1xn1wxgpgxpd"))))
     (build-system julia-build-system)
     (home-page "https://github.com/KristofferC/Crayons.jl")
     (synopsis "Colored and styled strings for terminals")
@@ -1614,7 +1645,7 @@ valuable enough at this time.")
     (inputs
      (list python-wrapper))
     (native-inputs
-     (list git-minimal/fixed                  ;needed for the "Utilities" test
+     (list git-minimal/pinned                  ;needed for the "Utilities" test
            julia-documentermarkdown
            julia-documentertools))
     (home-page "https://juliadocs.github.io/Documenter.jl")
@@ -2097,6 +2128,31 @@ types and sparsity.")
 using finite difference.")
     (license license:expat)))
 
+(define-public julia-fitsio
+  (package
+    (name "julia-fitsio")
+    (version "0.17.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaAstro/FITSIO.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "10w7cdb2cvcwpkcfdz2fwl4ji5rfdv8w9msc9gfd8d34k58bk8c5"))))
+    (build-system julia-build-system)
+    (native-inputs
+     (list julia-aqua julia-orderedcollections))
+    (propagated-inputs
+     (list julia-cfitsio julia-reexport julia-tables))
+    (home-page "https://github.com/JuliaAstro/CFITSIO.jl")
+    (synopsis "Astronomical FITS file support for Julia")
+    (description "This package provides Julia implementation for reading and
+writing @acronym{FITS, Flexible Image Transport System} files, based on the
+@code{cfitsio} library.")
+    (license license:expat)))
+
 (define-public julia-fixedpointnumbers
   (let ((commit "59ee94b93f2f1ee75544ef44187fc0e440cd8015")
         (revision "1"))
@@ -3439,7 +3495,7 @@ fixes.  The Julia IDE effort is pointed to extension for VSCode.")
 (define-public julia-latexstrings
   (package
     (name "julia-latexstrings")
-    (version "1.2.1")
+    (version "1.3.0")
     (source
       (origin
         (method git-fetch)
@@ -3448,7 +3504,7 @@ fixes.  The Julia IDE effort is pointed to extension for VSCode.")
                (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "117z27krcf8fydgp6mb0pgn75r4gng9qs7v90qb4bqzsry3faadp"))))
+         (base32 "0iijp96ca9mqg5skr6ps7q0lvqaa374lr2zkbbia5q6qgpq0j5ww"))))
     (build-system julia-build-system)
     (native-inputs
      (list julia-documenter))
@@ -3716,7 +3772,7 @@ TLS} and cryptography C library for Julia.")
 (define-public julia-measurements
   (package
     (name "julia-measurements")
-    (version "2.6.0")
+    (version "2.8.0")
     (source
       (origin
         (method git-fetch)
@@ -3725,14 +3781,15 @@ TLS} and cryptography C library for Julia.")
                (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "05p3f0gr4sv4maq8cix5fi8ldq0zagswqsd43xn6fhy046f936mz"))))
+         (base32 "1rn7qaf2s3l7awm8q5fjxlp1503g9mjgmsnvrbhjjvwyyn1k705r"))))
     (build-system julia-build-system)
     (propagated-inputs
      (list julia-calculus
            julia-recipesbase
            julia-requires))
     (native-inputs
-     (list julia-quadgk
+     (list julia-aqua
+           julia-quadgk
            julia-specialfunctions
            julia-unitful))
     (home-page "https://juliaphysics.github.io/Measurements.jl/stable/")
@@ -4077,7 +4134,7 @@ doesn't provide any other \"high-level\" functionality like layers or AD.")
 (define-public julia-optim
   (package
     (name "julia-optim")
-    (version "1.6.0")
+    (version "1.7.4")
     (source
       (origin
         (method git-fetch)
@@ -4086,7 +4143,7 @@ doesn't provide any other \"high-level\" functionality like layers or AD.")
                (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "0nvl3xp9c6r80y9n7fic4zyq2443apfmbcpnx0wvgkv4vsy08x5j"))))
+         (base32 "0pdwa2xm08c3g979qgsmcr343j4kkh4l6x5rdj1blhqh5gw8172b"))))
     (build-system julia-build-system)
     (arguments
      (list
@@ -4094,9 +4151,14 @@ doesn't provide any other \"high-level\" functionality like layers or AD.")
        #~(modify-phases %standard-phases
            (add-after 'unpack 'adjust-tests
              (lambda _
-               ;; TODO: Figure out why this test fails.
                (substitute* "test/runtests.jl"
-                 ((".*l_bfgs.*") "")))))))
+                 ;; Distributions.jl isn't packaged yet.
+                 ((".*newton_trust_region.*") ""))
+               (substitute*
+                 "test/multivariate/solvers/constrained/ipnewton/constraints.jl"
+                 ;; TODO: Figure out why this test fails.
+                 (("@test Optim\\.converged") "@test_skip Optim.converged")
+                 (("@test Optim\\.minimum") "@test_skip Optim.minimum")))))))
     (propagated-inputs
      (list julia-compat
            julia-fillarrays
@@ -4591,7 +4653,7 @@ Julia with little or no overhead (arrays are passed without making a copy).")
 (define-public julia-quadgk
   (package
     (name "julia-quadgk")
-    (version "2.4.1")
+    (version "2.5.0")
     (source
       (origin
         (method git-fetch)
@@ -4600,7 +4662,7 @@ Julia with little or no overhead (arrays are passed without making a copy).")
                (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "1hy0629yai6xflgxaflk9764lzr1lzhlghimxk1aqi212q9c6n33"))))
+         (base32 "0f14dhn0f7ln2j96qvmnsyy9ffzqsngd16ikc136snlxv4k4whiv"))))
     (build-system julia-build-system)
     (propagated-inputs
      (list julia-datastructures))