summary refs log tree commit diff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm103
1 files changed, 97 insertions, 6 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 56cff1ea6f..e5b159245c 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1119,6 +1119,49 @@ both the 256 color and 24 bit true color extensions, and the different text
 styles available to terminals.")
     (license license:expat)))
 
+(define-public julia-csv
+  (package
+    (name "julia-csv")
+    (version "0.10.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaData/CSV.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "15kjh5wa6ravb10n9n9bsh7ggmarqmw8s57p35l4b3dqk9d8qafh"))))
+    (build-system julia-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'fix-reference-to-cat
+                 (lambda _
+                   (substitute* "test/basics.jl"
+                     ;; XXXX: Test fail to read using CVS.Chunk; raising:
+                     ;; ArgumentError: unable to iterate chunks from input file source
+                     ;; Disable and the two tests using it.
+                     (("chunks = CSV.Chunks") "# chunks = CSV.Chunks")
+                     (("@test sum\\(length, chunks\\) == 10000")
+                      "# @test sum(length, chunks) == 10000")
+                     (("@test Tables.partitions\\(chunks\\) === chunks")
+                      "# @test Tables.partitions(chunks) === chunks")))))))
+    (propagated-inputs
+     (list julia-codeczlib
+           julia-filepathsbase
+           julia-inlinestrings
+           julia-parsers
+           julia-pooledarrays
+           julia-sentinelarrays
+           julia-tables
+           julia-weakrefstrings))
+    (home-page "https://github.com/JuliaData/CSV.jl")
+    (synopsis "Fast and flexible delimited-file reader/writer")
+    (description "This package provides reader/writer for delimited text data,
+as comma-delimited (csv), tab-delimited (tsv), or otherwise.")
+    (license license:expat)))
+
 (define-public julia-dataapi
   (package
     (name "julia-dataapi")
@@ -2847,6 +2890,32 @@ negative infinity in Julia.")
 interfaces with @file{.ini} files.")
     (license license:expat)))
 
+(define-public julia-inlinestrings
+  (package
+    (name "julia-inlinestrings")
+    (version "1.1.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaStrings/InlineStrings.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1dcdpxlphjliqlnkcri7mhg9bqqzpsdj80h9gkw8xhzr3ls473zr"))))
+    (build-system julia-build-system)
+    (propagated-inputs
+     (list julia-parsers))
+    (home-page "https://github.com/JuliaStrings/InlineStrings.jl")
+    (synopsis "Fixed-width string types")
+    (description "This package provides a set of custom string types of
+various fixed sizes.  Each inline string is a custom primitive type and can
+benefit from being stack friendly by avoiding allocations/heap tracking in the
+GC.  When used in an array, the elements are able to be stored inline since
+each one has a fixed size.  Currently support inline strings from 1 byte up to
+255 bytes.")
+    (license license:expat)))
+
 (define-public julia-interpolations
   (package
     (name "julia-interpolations")
@@ -3086,7 +3155,7 @@ extensions to the iterator interface.")
 (define-public julia-json
   (package
     (name "julia-json")
-    (version "0.21.1")
+    (version "0.21.3")
     (source
      (origin
        (method git-fetch)
@@ -3095,7 +3164,7 @@ extensions to the iterator interface.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1f9k613kbknmp4fgjxvjaw4d5sfbx8a5hmcszmp1w9rqfqngjx9m"))))
+        (base32 "1l2p852sxq6h5fif3dqshvbw17gb06jmq2nkr88spvp7s0n0nslz"))))
     (build-system julia-build-system)
     (propagated-inputs
      (list julia-datastructures
@@ -3946,7 +4015,7 @@ performance critical code.")
 (define-public julia-parsers
   (package
     (name "julia-parsers")
-    (version "1.1.0")
+    (version "2.2.4")
     (source
      (origin
        (method git-fetch)
@@ -3955,7 +4024,7 @@ performance critical code.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1gz3drd5334xrbx2ms33hiifkd0q1in4ywc92xvrkq3xgzdjqjdk"))))
+        (base32 "09v2x9yd1wdp74hzsf6218dpamlf2hb5nkmixqb4bc53ll8hpw4i"))))
     (build-system julia-build-system)
     (home-page "https://github.com/JuliaData/Parsers.jl")
     (synopsis "Fast parsing machinery for basic types in Julia")
@@ -4771,6 +4840,27 @@ user-friendly, scratch spaces should, in general, not be used for a storing
 files that the user must interact with through a file browser.")
     (license license:expat)))
 
+(define-public julia-sentinelarrays
+  (package
+    (name "julia-sentinelarrays")
+    (version "1.3.13")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaData/SentinelArrays.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1h3vpz7xskbf2a60imdg0irwh9bybkahjpnb6b3wyk0j9a97nqkr"))))
+    (build-system julia-build-system)
+    (home-page "https://github.com/JuliaData/SentinelArrays.jl")
+    (synopsis "Array types using sentinel values")
+    (description "This package provides @code{SentinelArray{T}} that wraps an
+@code{AbstractArray} of type @code{T}, and accepts a sentinel and value
+argument.")
+    (license license:expat)))
+
 (define-public julia-showoff
   (package
     (name "julia-showoff")
@@ -5625,7 +5715,7 @@ useful in order to support @code{VersionNumber} comparisons applied to
 (define-public julia-weakrefstrings
   (package
     (name "julia-weakrefstrings")
-    (version "1.1.0")
+    (version "1.4.0")
     (source
       (origin
         (method git-fetch)
@@ -5634,10 +5724,11 @@ useful in order to support @code{VersionNumber} comparisons applied to
                (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "14h1vdnc3rx87w6v2rr59lgb4kai2hd1wzqpxhmzsi8karg2z219"))))
+         (base32 "1ca94bpsjqrap2y9wlixspnisfkcms7aax0kpv7yn0v2vs9481wk"))))
     (build-system julia-build-system)
     (propagated-inputs
      (list julia-dataapi
+           julia-inlinestrings
            julia-parsers))
     (home-page "https://github.com/JuliaData/WeakRefStrings.jl")
     (synopsis "Efficient string representation and transfer in Julia")