summary refs log tree commit diff
path: root/gnu/packages/kawa.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kawa.scm')
-rw-r--r--gnu/packages/kawa.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/kawa.scm b/gnu/packages/kawa.scm
index 5771eeda8e..9550a01720 100644
--- a/gnu/packages/kawa.scm
+++ b/gnu/packages/kawa.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2019 Carlo Zancanaro <carlo@zancanaro.id.au>
 ;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -27,18 +28,25 @@
 (define-public kawa
   (package
     (name "kawa")
-    (version "3.0")
+    (version "3.1.1")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://gnu/kawa/kawa-" version ".tar.gz"))
        (sha256
-        (base32
-         "1k9qpydc64ar4aqyg3q7jmmxy503ayj85227qfhc5n6ngchqavhy"))))
+        (base32 "06g015zjlfgsx0n4lb326czkbf1grlx0n6dx074m808hdg6m16lc"))))
     (build-system gnu-build-system)
     (arguments
      `(#:parallel-build? #f
-       #:parallel-tests? #f))
+       #:parallel-tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'wrap-kawa
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (wrap-program (string-append out "/share/kawa/bin/kawa")
+                 `("JAVA_HOME" ":" = (,(assoc-ref inputs "icedtea"))))
+               #t))))))
     (inputs
      `(("icedtea" ,icedtea-8 "jdk")))
     (home-page "https://www.gnu.org/software/kawa/")