summary refs log tree commit diff
path: root/gnu/packages/kde-pim.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde-pim.scm')
-rw-r--r--gnu/packages/kde-pim.scm94
1 files changed, 50 insertions, 44 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index f5b0c008ce..1ed90b95c1 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -2,6 +2,8 @@
 ;;; Copyright © 2017, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2022 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -34,7 +36,6 @@
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages kde)
   #:use-module (gnu packages kde-frameworks)
-  #:use-module (gnu packages kde-internet)
   #:use-module (gnu packages openldap)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages search)
@@ -105,7 +106,7 @@
                       get-string-all))))
                (rename-file "CMakeLists.txt.new" "CMakeLists.txt"))
              #t)))))
-    (home-page "https://kontact.kde.org/components/akonadi.html")
+    (home-page "https://kontact.kde.org/components/akonadi/")
     (synopsis "Extensible cross-desktop storage service for PIM")
     (description "Akonadi is an extensible cross-desktop Personal Information
 Management (PIM) storage service.  It provides a common framework for
@@ -440,7 +441,7 @@ Akonadi PIM data server.  It uses Xapian for indexing and querying.")
            prison
            qgpgme
            qtbase-5))
-    (home-page "https://kontact.kde.org/components/kaddressbook.html")
+    (home-page "https://kontact.kde.org/components/kaddressbook/")
     (synopsis "Address Book application to manage your contacts")
     (description "KAddressBook stores all the personal details of your family,
 friends and other contacts.  It supports large variety of services, including
@@ -561,7 +562,7 @@ one of the APIs mentioned above.")
            ktextwidgets
            kxmlgui
            qtbase-5))
-    (home-page "https://api.kde.org/stable/calendarsupport/")
+    (home-page "https://api.kde.org/kdepim/calendarsupport/html/index.html")
     (synopsis "Calendar Support library for KDE PIM")
     (description "The Calendar Support library provides helper utilities for
 calendaring applications.")
@@ -599,37 +600,13 @@ calendaring applications.")
            qtbase-5))
     (arguments
      `(#:tests? #f)) ;; TODO: seem to pull in some wrong theme
-    (home-page "https://api.kde.org/stable/kdepimlibs-apidocs/")
+    (home-page "https://api.kde.org/kdepim/kcalutils/html/index.html")
     (synopsis "Library with utility functions for the handling of calendar
 data")
     (description "This library provides a utility and user interface
 functions for accessing calendar data using the kcalcore API.")
     (license  license:lgpl2.0+)))
 
-(define-public kdav
-  (package
-    (name "kdav")
-    (version "20.04.3")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "mirror://kde/stable/release-service/" version
-                           "/src/kdav-" version ".tar.xz"))
-       (sha256
-        (base32 "0445gl4xm0h39igkxgb6vmq5iaa04wkgrgbs7nfd0zwngk8xaidn"))))
-    (build-system qt-build-system)
-    (native-inputs
-     (list extra-cmake-modules))
-    (inputs
-     (list kcoreaddons ki18n kio qtbase-5 qtxmlpatterns))
-    (home-page "https://invent.kde.org/frameworks/kdav")
-    (synopsis "DAV protocol implementation with KJobs")
-    (description "This is a DAV protocol implementation with KJobs.  Calendars
-and todos are supported, using either GroupDAV or CalDAV, and contacts are
-supported using GroupDAV or CardDAV.")
-    (license ;; GPL for programs, LGPL for libraries
-     (list license:gpl2+ license:lgpl2.0+))))
-
 (define-public kdepim-apps-libs
   (package
     (name "kdepim-apps-libs")
@@ -843,7 +820,7 @@ package.")
            kxmlgui
            oxygen-icons ;; default icon set
            qtbase-5))
-    (home-page "https://kde.org/applications/utilities/org.kde.kgpg")
+    (home-page "https://apps.kde.org/kgpg/")
     (synopsis "Graphical front end for GNU Privacy Guard")
     (description "Kgpg manages cryptographic keys for the GNU Privacy Guard,
 and can encrypt, decrypt, sign, and verify files.  It features a simple editor
@@ -911,7 +888,7 @@ cryptography to the contents of the clipboard.")
            kio
            kmime
            qtbase-5))
-    (home-page "https://api.kde.org/stable/kdepimlibs-apidocs/")
+    (home-page "https://api.kde.org/kdepim/kimap/html/index.html")
     (synopsis "Library for handling IMAP")
     (description "This library provides a job-based API for interacting with
 an IMAP4rev1 server.  It manages connections, encryption and parameter quoting
@@ -939,7 +916,7 @@ easier to do so.")
      (list ki18n kio kwidgetsaddons qtbase-5))
     (propagated-inputs
      (list cyrus-sasl openldap))
-    (home-page "https://api.kde.org/stable/kdepimlibs-apidocs/")
+    (home-page "https://api.kde.org/kdepim/kldap/html/index.html")
     (synopsis "Library for accessing LDAP")
     (description " This is a library for accessing LDAP with a convenient Qt
 style C++ API.  LDAP (Lightweight Directory Access Protocol) is an application
@@ -993,7 +970,7 @@ protocol for querying and modifying directory services running over TCP/IP.")
              (when tests?
                (invoke "dbus-launch" "ctest" "."))
              #t)))))
-    (home-page "https://kde.org/applications/utilities/org.kde.kleopatra")
+    (home-page "https://apps.kde.org/kleopatra/")
     (synopsis "Certificate Manager and Unified Crypto GUI")
     (description "Kleopatra is a certificate manager and a universal crypto
 GUI.  It supports managing X.509 and OpenPGP certificates in the GpgSM keybox
@@ -1082,7 +1059,7 @@ and retrieving certificates from LDAP servers.")
              (when tests?
                (invoke "dbus-launch" "ctest" "."))
              #t)))))
-    (home-page "https://kontact.kde.org/components/kmail.html")
+    (home-page "https://kontact.kde.org/components/kmail/")
     (synopsis "Full featured graphical email client")
     (description "KMail supports multiple accounts, mail filtering and email
 encryption.  The program let you configure your workflow and it has good
@@ -1232,7 +1209,7 @@ e-mail client programs into KMail and KDE PIM.")
            qtbase-5))
     (arguments
      `(#:tests? #f)) ;; TODO - 3/3 tests fail, require drkonqi
-    (home-page "https://api.kde.org/stable/kdepimlibs-apidocs/")
+    (home-page "https://api.kde.org/kdepim/kmailtransport/html/index.html")
     (synopsis "Mail transport service library")
     (description "This library provides an API and support code for managing
 mail transport.")
@@ -1254,7 +1231,7 @@ mail transport.")
      (list extra-cmake-modules))
     (inputs
      (list kcodecs kmime qtbase-5))
-    (home-page "https://api.kde.org/stable/kdepimlibs-apidocs/")
+    (home-page "https://api.kde.org/kdepim/kmbox/html/index.html")
     (synopsis "Library for handling mbox mailboxes")
     (description "This is a library for handling mailboxes in mbox format,
 using a Qt/KMime C++ API.")
@@ -1325,7 +1302,6 @@ using a Qt/KMime C++ API.")
            qtdeclarative-5
            qtwebchannel-5
            qtwebengine-5
-           qtwebkit
            sonnet))
     (arguments
      `(#:tests? #f     ;TODO many test fail for quite different reasons
@@ -1374,7 +1350,7 @@ kwebengineviewer.")
                (("(Today|Yesterday) 12:34:56" line day)
                 (string-append day " 12:34 PM")))
              #t)))))
-    (home-page "https://api.kde.org/stable/kdepimlibs-apidocs/")
+    (home-page "https://api.kde.org/kdepim/kmime/html/index.html")
     (synopsis "Library for handling MIME data")
     (description "This library provides an API for handling MIME
 data.  MIME (Multipurpose Internet Mail Extensions) is an Internet Standard
@@ -1440,7 +1416,7 @@ information in non-ASCII character sets.")
            oxygen-icons ; default icon set, required for tests
            qtbase-5
            qtx11extras))
-    (home-page "https://kontact.kde.org/components/knotes.html")
+    (home-page "https://apps.kde.org/knotes/")
     (synopsis "Note-taking utility")
     (description "KNotes lets you write the computer equivalent of sticky
 notes.  The notes are saved automatically when you exit the program, and they
@@ -1477,9 +1453,9 @@ Features:
            kwindowsystem
            kxmlgui
            qtbase-5))
-    (home-page "https://api.kde.org/stable/kdepimlibs-apidocs/")
+    (home-page "https://api.kde.org/kdepim/kontactinterface/html/index.html")
     (synopsis "Kontact interface library")
-    (description " This library provides the glue necessary for
+    (description "This library provides the glue necessary for
 application \"Parts\" to be embedded as a Kontact component (or plugin).")
     (license license:lgpl2.0+)))
 
@@ -1562,7 +1538,7 @@ application \"Parts\" to be embedded as a Kontact component (or plugin).")
              (when tests?
                (invoke "dbus-launch" "ctest" "."))
              #t)))))
-    (home-page "https://kontact.kde.org/components/korganizer.html")
+    (home-page "https://apps.kde.org/korganizer/")
     (synopsis "Organizational assistant, providing calendars and other similar
 functionality to help you organize your life.")
     (description "KOrganizer is the calendar and scheduling component of
@@ -1665,6 +1641,36 @@ Virtual Contact File}) files to the KPeople contact management library.")
     (license ;; GPL for programs, LGPL for libraries
      (list license:gpl2+ license:lgpl2.0+))))
 
+(define-public libgravatar
+  (package
+    (name "libgravatar")
+    (version "20.04.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/release-service/" version
+                           "/src/libgravatar-" version ".tar.xz"))
+       (sha256
+        (base32 "0981ci2kr20v4fk11h57rqya0brgslfazpgq1yk5yqiwyqqm49r2"))))
+    (build-system qt-build-system)
+    (native-inputs (list extra-cmake-modules))
+    (inputs (list kconfig
+                  ki18n
+                  kio
+                  kpimcommon
+                  ktextwidgets
+                  kwidgetsaddons
+                  qtbase-5))
+    (arguments
+     `(#:tests? #f)) ;; 2/7 tests fail (due to network issues?)
+    (home-page "https://invent.kde.org/pim/libgravatar")
+    (synopsis "Online avatar lookup library")
+    (description "This library retrieves avatar images based on a
+hash from a person's email address, as well as local caching to avoid
+unnecessary network operations.")
+    (license ;; GPL for programs, LGPL for libraries
+     (list license:gpl2+ license:lgpl2.0+))))
+
 (define-public kpimtextedit
   (package
     (name "kpimtextedit")
@@ -1698,7 +1704,7 @@ Virtual Contact File}) files to the KPeople contact management library.")
            sonnet))
     (arguments
      `(#:tests? #f)) ;; TODO - test suite hangs
-    (home-page "https://api.kde.org/stable/kdepimlibs-apidocs/")
+    (home-page "https://api.kde.org/kdepim/kpimtextedit/html/index.html")
     (synopsis "Library providing a textedit with PIM-specific features")
     (description "This package provides a textedit with PIM-specific features.
 It also provides so-called rich text builders which can convert the formatted
@@ -1769,7 +1775,7 @@ standard protocols for e-mail transmission.")
            kcoreaddons
            ki18n
            qtbase-5))
-    (home-page "https://api.kde.org/stable/kdepimlibs-apidocs/ktnef/html/")
+    (home-page "https://api.kde.org/kdepim/ktnef/html/index.html")
     (synopsis "Library for handling mail attachments using TNEF format")
     (description "Ktnef is a library for handling data in the TNEF
 format (Transport Neutral Encapsulation Format, a proprietary format of e-mail