summary refs log tree commit diff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index eded039ee6..e96b11fa30 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -415,6 +415,36 @@ Each of the red, green, and blue components can be adjusted individually, or
 all three components can be adjusted together.")
     (license license:gpl2+)))
 
+(define-public khotkeys
+  (package
+    (name "khotkeys")
+    (version "5.19.5")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://kde/stable/plasma/" version
+                          "/khotkeys-" version ".tar.xz"))
+      (sha256
+       (base32 "1nhvnflq7nzxkyfnzx1vdvjh4yrpi1qsf6mjjrnpg8w5ncgbd32n"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("kcmutils" ,kcmutils)
+       ("kdbusaddons" ,kdbusaddons)
+       ("kdelibs4support" ,kdelibs4support)
+       ("kglobalaccel" ,kglobalaccel)
+       ("ki18n" ,ki18n)
+       ("kio" ,kio)
+       ("kxmlgui" ,kxmlgui)
+       ("plasma-framwork" ,plasma-framework)
+       ("plasma-workspace" ,plasma-workspace)
+       ("qtx11extras" ,qtx11extras)))
+    (home-page "https://invent.kde.org/plasma/khotkeys")
+    (synopsis "Configure input actions for KDE Plasma")
+    (description "KHotKeys is core-part of the KDE Plasma desktop.")
+    (license license:gpl2+)))
+
 (define-public kscreen
   (package
     (name "kscreen")