summary refs log tree commit diff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm73
1 files changed, 33 insertions, 40 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index bcf7146782..dcb91fdb0b 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -11,7 +11,7 @@
 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Prafulla Giri <pratheblackdiamond@gmail.com>
-;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2021 Alexandros Theodotou <alex@zrythm.org>
 ;;; Copyright © 2021 la snesne <lasnesne@lagunposprasihopre.org>
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
@@ -219,7 +219,7 @@ browser for easy news reading.")
     (license license:gpl2+)))
 
 (define-public kdenlive
-  (let ((version "20.08.3"))
+  (let ((version "21.08.2"))
     (package
       (name "kdenlive")
       (version version)
@@ -231,45 +231,48 @@ browser for easy news reading.")
                (commit (string-append "v" version))))
          (file-name (string-append name "-" version "-checkout"))
          (sha256
-          (base32 "0x0qfwf6wfnybjyjvmllpf87sm27d1n2akslhp2k8ins838qy55i"))))
-      (build-system cmake-build-system)
+          (base32 "1l78xjdf1bmj3s8kysaqqgh67mb3vrc96rsdnp0i4awlyfsh89d7"))))
+      (build-system qt-build-system)
       (native-inputs
        `(("extra-cmake-modules" ,extra-cmake-modules)
          ("pkg-config" ,pkg-config)
          ("qttools" ,qttools)))
       (inputs
-       `(("shared-mime-info" ,shared-mime-info)
-         ("frei0r-plugins" ,frei0r-plugins)
+       `(("breeze" ,breeze) ; make dark them available easily
+         ("breeze-icons" ,breeze-icons) ; recommended icon set
          ("ffmpeg" ,ffmpeg)
-         ("rttr" ,rttr)
-         ("mlt" ,mlt-6)
-         ("qtbase" ,qtbase-5)
-         ("qtscript" ,qtscript)
-         ("qtsvg" ,qtsvg)
-         ("qtmultimedia" ,qtmultimedia)
-         ("kparts" ,kparts)
-         ("knotifications" ,knotifications)
+         ("frei0r-plugins" ,frei0r-plugins)
          ("karchive" ,karchive)
-         ("kdbusaddons" ,kdbusaddons)
          ("kcrash" ,kcrash)
+         ("kdbusaddons" ,kdbusaddons)
+         ("kdeclarative" ,kdeclarative)
+         ("kdoctools" ,kdoctools)
+         ("kfilemetadata" ,kfilemetadata)
          ("kguiaddons" ,kguiaddons)
+         ("kiconthemes" ,kiconthemes)
          ("knewstuff" ,knewstuff)
+         ("knotifications" ,knotifications)
          ("knotifyconfig" ,knotifyconfig)
-         ("kfilemetadata" ,kfilemetadata)
-         ("kdoctools" ,kdoctools)
-         ("kdeclarative" ,kdeclarative)
+         ("kparts" ,kparts)
+         ("kplotting" ,kplotting)
+         ("mlt" ,mlt)
+         ("purpose" ,purpose)
+         ("qtbase" ,qtbase-5)
          ("qtdeclarative" ,qtdeclarative)
+         ("qtgraphicaleffects" ,qtgraphicaleffects)
+         ("qtmultimedia" ,qtmultimedia)
+         ("qtnetworkauth" ,qtnetworkauth)
          ("qtquickcontrols" ,qtquickcontrols)
          ("qtquickcontrols2" ,qtquickcontrols2)
-         ("kiconthemes" ,kiconthemes)
-         ("breeze" ,breeze) ; make dark them available easily
-         ("breeze-icons" ,breeze-icons) ; recommended icon set
-         ("purpose" ,purpose)
+         ("qtscript" ,qtscript)
+         ("qtsvg" ,qtsvg)
          ("qtwebkit" ,qtwebkit)
-         ("qtgraphicaleffects" ,qtgraphicaleffects)
-         ("kplotting" ,kplotting)))
+         ("shared-mime-info" ,shared-mime-info)))
       (arguments
-       `(#:tests? #f                    ;TODO needs X
+       ;; XXX: there is a single test that spawns other tests and
+       ;; 1/3 tests failed and 1/327 assertions failed.  It seems
+       ;; that individual tests can't be skipped.
+       `(#:tests? #f
          #:phases
          (modify-phases %standard-phases
            (add-after 'install 'wrap-executable
@@ -277,26 +280,16 @@ browser for easy news reading.")
                (let* ((out (assoc-ref outputs "out"))
                       (qtbase (assoc-ref inputs "qtbase"))
                       (frei0r (assoc-ref inputs "frei0r-plugins"))
-                      (ffmpeg (assoc-ref inputs "ffmpeg"))
-                      (breeze (assoc-ref inputs "breeze"))
-                      (breeze-icons (assoc-ref inputs "breeze-icons")))
+                      (ffmpeg (assoc-ref inputs "ffmpeg")))
                  (wrap-program (string-append out "/bin/kdenlive")
                    `("PATH" ":" prefix
                      ,(list (string-append ffmpeg "/bin")))
-                   `("XDG_DATA_DIRS" ":" prefix
-                     ,(list (string-append breeze "/share")
-                            (string-append breeze-icons "/share")))
-                   `("QT_PLUGIN_PATH" ":" prefix
-                     ,(list (getenv "QT_PLUGIN_PATH")))
                    `("FREI0R_PATH" ":" =
                      (,(string-append frei0r "/lib/frei0r-1/")))
                    `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
                      (,(string-append qtbase "/lib/qt5/plugins/platforms")))
-                   `("QML2_IMPORT_PATH" ":" prefix
-                     ,(list (getenv "QML2_IMPORT_PATH")))
                    `("MLT_PREFIX" ":" =
-                     (,(assoc-ref inputs "mlt")))))
-               #t)))))
+                     (,(assoc-ref inputs "mlt"))))))))))
       (home-page "https://kdenlive.org")
       (synopsis "Non-linear video editor")
       (description "Kdenlive is an acronym for KDE Non-Linear Video Editor.
@@ -461,7 +454,7 @@ illustrate project schedules.")
 (define-public krita
   (package
     (name "krita")
-    (version "4.4.5")
+    (version "4.4.8")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -469,7 +462,7 @@ illustrate project schedules.")
                     "/krita-" version ".tar.gz"))
               (sha256
                (base32
-                "0s3mzgkxb316y1wncrr8l3w5nnqszhvdh8qi1nh6040dhy075zab"))))
+                "1y0d8gnxfdg5nfwk8dgx8fc2bwskvnys049napb1a9fr25bqmimw"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f
@@ -537,7 +530,7 @@ illustrate project schedules.")
        ("qtmultimedia" ,qtmultimedia)
        ("qtsvg" ,qtsvg)
        ("qtx11extras" ,qtx11extras)
-       ("quazip" ,quazip)
+       ("quazip" ,quazip-0)
        ("zlib" ,zlib)))
     (home-page "https://krita.org")
     (synopsis "Digital painting application")