summary refs log tree commit diff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm82
1 files changed, 41 insertions, 41 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index b56b63e784..aa742df80f 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -170,7 +170,7 @@ This package contains GUI widgets for baloo.")
              (let* ((out (assoc-ref outputs "out"))
                     (bin (string-append out "/bin/akregator"))
                     (qt-process-path (string-append
-                                       (assoc-ref inputs "qtwebengine")
+                                       (assoc-ref inputs "qtwebengine-5")
                                        "/lib/qt5/libexec/QtWebEngineProcess")))
                (wrap-program bin
                  `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
@@ -205,9 +205,9 @@ This package contains GUI widgets for baloo.")
            libkleo
            qgpgme
            qtbase-5
-           qtdeclarative
-           qtwebchannel
-           qtwebengine
+           qtdeclarative-5
+           qtwebchannel-5
+           qtwebengine-5
            syndication))
     (home-page "https://apps.kde.org/en/akregator")
     (synopsis "KDE Feed Reader")
@@ -261,7 +261,7 @@ browser for easy news reading.")
                   `("MLT_PREFIX" ":" =
                     (,#$(this-package-input "mlt"))))))))))
     (native-inputs
-     (list extra-cmake-modules pkg-config qttools))
+     (list extra-cmake-modules pkg-config qttools-5))
     (inputs
      (list bash-minimal
            breeze                       ; make dark them available easily
@@ -285,14 +285,14 @@ browser for easy news reading.")
            mlt
            purpose
            qtbase-5
-           qtdeclarative
+           qtdeclarative-5
            qtgraphicaleffects
-           qtmultimedia
-           qtnetworkauth
-           qtquickcontrols
-           qtquickcontrols2
+           qtmultimedia-5
+           qtnetworkauth-5
+           qtquickcontrols-5
+           qtquickcontrols2-5
            qtscript
-           qtsvg
+           qtsvg-5
            shared-mime-info))
     (home-page "https://kdenlive.org")
     (synopsis "Non-linear video editor")
@@ -318,7 +318,7 @@ projects.")
          (base32 "02ip5r67hjfpywkm3mz86n6wbqcr7996ifzfd2fyzsvm4998hi4y"))))
     (build-system qt-build-system)
     (native-inputs
-     (list extra-cmake-modules pkg-config shared-mime-info qttools))
+     (list extra-cmake-modules pkg-config shared-mime-info qttools-5))
     (inputs
      `(("boost" ,boost)
        ("clang" ,clang)
@@ -345,9 +345,9 @@ projects.")
        ("libkomparediff2" ,libkomparediff2)
        ("oxygen-icons" ,oxygen-icons)
        ("qtbase" ,qtbase-5)
-       ("qtdeclarative" ,qtdeclarative)
-       ("qtquickcontrols" ,qtquickcontrols)  ;; not checked as requirement
-       ("qtquickcontrols2" ,qtquickcontrols2)  ;; not checked as requirement
+       ("qtdeclarative-5" ,qtdeclarative-5)
+       ("qtquickcontrols-5" ,qtquickcontrols-5)  ;; not checked as requirement
+       ("qtquickcontrols2-5" ,qtquickcontrols2-5)  ;; not checked as requirement
        ("qtwebkit" ,qtwebkit)
        ("threadweaver" ,threadweaver)
 
@@ -436,9 +436,9 @@ for some KDevelop language plugins (Ruby, PHP, CSS...).")
                  "kdiagram-Fix-missing-link-libraries.patch"))))
     (build-system qt-build-system)
     (native-inputs
-     (list extra-cmake-modules qttools))
+     (list extra-cmake-modules qttools-5))
     (inputs
-     (list qtbase-5 qtsvg))
+     (list qtbase-5 qtsvg-5))
     (home-page "https://invent.kde.org/graphics/kdiagram")
     (synopsis "Libraries for creating business diagrams")
     (description "This package provides libraries for integrating business
@@ -539,9 +539,9 @@ expression library, that is used in Krita.")
            perl
            poppler-qt5
            qtbase-5
-           qtdeclarative
-           qtmultimedia
-           qtsvg
+           qtdeclarative-5
+           qtmultimedia-5
+           qtsvg-5
            qtx11extras
            quazip-0
            zlib))
@@ -577,7 +577,7 @@ features include brush stabilizers, brush engines and wrap-around mode.")
            kio
            ki18n
            qtbase-5
-           qtsvg
+           qtsvg-5
            qtxmlpatterns))
     (home-page "https://apps.kde.org/en/massif-visualizer")
     (synopsis "Visualize massif data generated by Valgrind")
@@ -690,7 +690,7 @@ cards.")
     (inputs
      (list qtbase-5))
     (native-inputs
-     (list extra-cmake-modules qttools))
+     (list extra-cmake-modules qttools-5))
     (home-page "https://techbase.kde.org/Projects/Snorenotify")
     (synopsis "Qt notification framework")
     (description "Snorenotify is a multi platform Qt notification framework.
@@ -745,11 +745,11 @@ different notification systems.")
            pulseaudio-qt
            qca
            qtbase-5
-           qtdeclarative
+           qtdeclarative-5
            qtgraphicaleffects
-           qtmultimedia
-           qtquickcontrols
-           qtquickcontrols2
+           qtmultimedia-5
+           qtquickcontrols-5
+           qtquickcontrols2-5
            qtx11extras))
     (home-page "https://community.kde.org/KDEConnect")
     (synopsis "Enable your devices to communicate with each other")
@@ -804,7 +804,7 @@ communicate with each other.  Here's a few things KDE Connect can do:
        ("extra-cmake-modules" ,extra-cmake-modules)
        ("pkg-config" ,pkg-config)
        ("python" ,python-wrapper)
-       ("qttools" ,qttools)))
+       ("qttools-5" ,qttools-5)))
     (inputs
      (list breeze ;for dark themes
            breeze-icons ;for icons
@@ -828,7 +828,7 @@ communicate with each other.  Here's a few things KDE Connect can do:
            kwidgetsaddons
            kxmlgui
            qtbase-5
-           qtsvg
+           qtsvg-5
            shared-mime-info
            ;; Optional.
            cfitsio
@@ -863,7 +863,7 @@ to perform data analysis.")
     (native-inputs
      (list extra-cmake-modules))
     (inputs
-     (list qtbase-5 qtdeclarative))
+     (list qtbase-5 qtdeclarative-5))
     (home-page "https://phabricator.kde.org/source/kqtquickcharts/")
     (synopsis "Interactive charts for Qt Quick")
     (description
@@ -917,7 +917,7 @@ unmount drives and view them in a file manager.")
                 "0fx17s6fj1pxl1mgfrqhchk8sihkbji1x8y3nhb1r0971wzd1nsc"))))
     (build-system cmake-build-system)
     (native-inputs
-     (list extra-cmake-modules perl python qttools kdoctools))
+     (list extra-cmake-modules perl python qttools-5 kdoctools))
     (inputs
      (list qtbase-5 karchive ki18n kio kdbusaddons))
     ;; Note: The 'hotshot2calltree' and 'pprof2calltree' scripts depend on
@@ -977,8 +977,8 @@ Python, PHP, and Perl.")
            libsndfile
            openal
            qtbase-5
-           qtdeclarative
-           qtsvg))
+           qtdeclarative-5
+           qtsvg-5))
     (home-page "https://games.kde.org/")
     (synopsis "Runtime library for kdegames")
     (description "Runtime library for kdegames")
@@ -1007,7 +1007,7 @@ Python, PHP, and Perl.")
              "-DBUILD_TOUCH=YES"
              "-DBUILD_MARBLE_TESTS=FALSE")))
     (native-inputs
-     (list extra-cmake-modules qttools))
+     (list extra-cmake-modules qttools-5))
     ;; One optional dependency missing: libwlocate.
     (inputs
      (list gpsd
@@ -1024,12 +1024,12 @@ Python, PHP, and Perl.")
            phonon
            protobuf
            qtbase-5
-           qtdeclarative
+           qtdeclarative-5
            qtlocation
            qtserialport
-           qtsvg
-           qtwebchannel
-           qtwebengine
+           qtsvg-5
+           qtwebchannel-5
+           qtwebengine-5
            shapelib
            shared-mime-info
            zlib))
@@ -1094,8 +1094,8 @@ creating routes by drag and drop and more.")
            phonon
            poppler-qt5
            qca
-           qtdeclarative
-           qtsvg
+           qtdeclarative-5
+           qtsvg-5
            threadweaver
            kcrash
            kjs))
@@ -1216,7 +1216,7 @@ or Bonjour by other projects).")
     (build-system qt-build-system)
     (native-inputs
      (list extra-cmake-modules
-           qttools
+           qttools-5
            ;; For optional component "Survey target expression parser"
            bison
            flex
@@ -1225,7 +1225,7 @@ or Bonjour by other projects).")
            ;;("phpunit" ,phpunit)
            ))
     (inputs
-     (list qtbase-5 qtcharts qtdeclarative qtsvg))
+     (list qtbase-5 qtcharts qtdeclarative-5 qtsvg-5))
     (arguments
      `(#:tests? #f))  ;; 4/17 fail
     (home-page "https://api.kde.org/frameworks/kuserfeedback/html/")