summary refs log tree commit diff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm20
1 files changed, 8 insertions, 12 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index aff3ed51ed..bcf7146782 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -7,7 +7,7 @@
 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2018, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
-;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Prafulla Giri <pratheblackdiamond@gmail.com>
@@ -715,17 +715,13 @@ different notification systems.")
     (arguments
      `(#:configure-flags '("-DBUILD_TESTING=ON"
                            "-DKDE_INSTALL_LIBEXECDIR=libexec")
-       #:phases (modify-phases %standard-phases
-                  (add-after 'set-paths 'extend-CPLUS_INCLUDE_PATH
-                    (lambda* (#:key inputs #:allow-other-keys)
-                      ;; FIXME: <kcmutils_version.h> is not found during one
-                      ;; of the compilation steps without this hack.
-                      (setenv "CPLUS_INCLUDE_PATH"
-                              (string-append (assoc-ref inputs "kcmutils")
-                                             "/include/KF5:"
-                                             (or (getenv "CPLUS_INCLUDE_PATH")
-                                                 "")))
-                      #t)))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'adjust-include-header
+           (lambda _
+             (substitute* "plugins/runcommand/runcommandplugin.cpp"
+               (("<kcmutils_version.h>")
+                "<KF5/kcmutils_version.h>")))))
        #:tests? #f)) ; tests fail hard in our build environment
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)