summary refs log tree commit diff
path: root/gnu/packages/libevent.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/libevent.scm')
-rw-r--r--gnu/packages/libevent.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 64892bf878..2afae3f302 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -73,12 +73,12 @@ loop.")
                 "1ys2wlypdbv59yywn91d5vl329z50mi7ivi3fj5rjm4mr9g3wnmr"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (alist-cons-before
-                 'configure 'autogen
+     '(#:phases (alist-cons-after
+                 'unpack 'autogen
                  (lambda _
                    ;; Fashionable people don't run 'make dist' these days, so
                    ;; we need to do that ourselves.
-                   (zero? (system* "./autogen.sh")))
+                   (zero? (system* "sh" "autogen.sh")))
                  %standard-phases)
 
        ;; XXX: Some tests want /dev/tty, attempt to make connections, etc.