summary refs log tree commit diff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 9571ba6e7d..f373383a8a 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -740,6 +740,9 @@ Works word processor file format.")
       (sha256 (base32
                "08mg5kmkjrmqrd8j5rkzw9vdqlvibhb1ynp6bmfxnzq5rcq1l197"))))
    (build-system gnu-build-system)
+   (arguments
+    ;; A harmless 'sign-compare' error pops up on i686 so disable '-Werror'.
+    '(#:configure-flags '("--disable-werror")))
    (inputs
     `(("boost" ,boost)
       ("icu4c" ,icu4c)
@@ -1102,6 +1105,8 @@ converting QuarkXPress file format.  It supports versions 3.1 to 4.1.")
         (list
           "--enable-release-build"
           "--enable-verbose"
+          ;; Avoid using all cpu cores by default
+          (format #f "--with-parallelism=~d" (parallel-job-count))
           "--disable-fetch-external" ; disable downloads
           "--with-system-libs" ; enable all --with-system-* flags
           (string-append "--with-boost-libdir="