summary refs log tree commit diff
path: root/gnu/packages/libunistring.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/libunistring.scm')
-rw-r--r--gnu/packages/libunistring.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/libunistring.scm b/gnu/packages/libunistring.scm
index fda839be54..eccd053a35 100644
--- a/gnu/packages/libunistring.scm
+++ b/gnu/packages/libunistring.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2018, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
@@ -27,6 +27,7 @@
   #:use-module (guix licenses)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix gexp)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
   #:use-module (gnu packages base))
@@ -34,7 +35,7 @@
 (define-public libunistring
   (package
    (name "libunistring")
-   (version "0.9.10")
+   (version "1.0")
    (source (origin
             (method url-fetch)
             (uri (string-append
@@ -42,7 +43,7 @@
                   version ".tar.xz"))
             (sha256
              (base32
-              "1mq57h06622m6qc5cv347fc3qk5mj840axw3c0vd7qmnwk1v53zb"))))
+              "0h97qx3c4970wvh25g51sjgz54xn37lrfy95dg97xmvmkys5basv"))))
    (propagated-inputs (libiconv-if-needed))
    (outputs '("out" "static"))
    (build-system gnu-build-system)
@@ -50,21 +51,20 @@
     ;; Work around parallel build issue whereby C files may be compiled before
     ;; config.h is built: see <http://hydra.gnu.org/build/59381/nixlog/2/raw> and
     ;; <http://lists.openembedded.org/pipermail/openembedded-core/2012-April/059850.html>.
-    '(#:parallel-build? #f
-      #:phases (modify-phases %standard-phases
-                 (add-after 'install 'move-static-library
-                   (lambda* (#:key outputs #:allow-other-keys)
-                     (let ((out (assoc-ref outputs "out"))
-                           (static (assoc-ref outputs "static")))
-                       (with-directory-excursion (string-append out "/lib")
-                         (install-file "libunistring.a"
-                                       (string-append static "/lib"))
-                         (delete-file "libunistring.a")
-                         #t)))))))
+    (list
+      #:parallel-build? #f
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'install 'move-static-library
+            (lambda* (#:key outputs #:allow-other-keys)
+              (with-directory-excursion (string-append #$output "/lib")
+                (install-file "libunistring.a"
+                              (string-append #$output:static "/lib"))
+                (delete-file "libunistring.a")))))))
    (synopsis "C library for manipulating Unicode strings")
    (description
     "GNU libunistring is a library providing functions to manipulate
 Unicode strings and for manipulating C strings according to the Unicode
 standard.")
    (home-page "https://www.gnu.org/software/libunistring/")
-   (license (list lgpl3+ gpl2))))
+   (license (list lgpl3+ gpl2+))))