summary refs log tree commit diff
path: root/gnu/packages/lighting.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lighting.scm')
-rw-r--r--gnu/packages/lighting.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/lighting.scm b/gnu/packages/lighting.scm
index 7f01cdbc99..ab7069b53b 100644
--- a/gnu/packages/lighting.scm
+++ b/gnu/packages/lighting.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -59,7 +60,9 @@
        ("libuuid" ,util-linux)
        ("zlib" ,zlib)))
     (propagated-inputs
-     `(("protobuf" ,protobuf))) ;; for pkg-config --libs libola
+     ;; Ola 0.10.5 only supports protobuf 2.x, and building it with 3.x breaks.
+     ;; XXX Remove protobuf-2 when it is no longer needed.
+     `(("protobuf" ,protobuf-2))) ;; for pkg-config --libs libola
     (arguments
      `(;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
        ;; build to fail on low memory systems.  We disable that with the