summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm124
1 files changed, 74 insertions, 50 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 464b7a8427..968beb52ee 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -404,17 +404,39 @@ It has been modified to remove all non-free binary blobs.")
 ;; supports qemu "virt" machine and possibly a large number of ARM boards.
 ;; See : https://wiki.debian.org/DebianKernel/ARMMP.
 
-(define %linux-libre-version "4.17.14")
-(define %linux-libre-hash "11yf4s3cq6a9z3sl38kr4li75mhqfnmgwayi1mcaac8hr6ylksss")
+(define %linux-libre-version "4.18.3")
+(define %linux-libre-hash "0z7nnkmk5d2npilviqxa0m6nn30f5arhviysby78kkb3j2isx9jx")
+
+(define %linux-libre-4.18-patches
+  (list %boot-logo-patch
+        (origin
+          (method url-fetch)
+          (uri (string-append
+                "https://salsa.debian.org/kernel-team/linux"
+                "/raw/34a7d9011fcfcfa38b68282fd2b1a8797e6834f0"
+                "/debian/patches/bugfix/arm/"
+                "arm-mm-export-__sync_icache_dcache-for-xen-privcmd.patch"))
+          (file-name "linux-libre-4.18-arm-export-__sync_icache_dcache.patch")
+          (sha256
+           (base32 "1ifnfhpakzffn4b8n7x7w5cps9mzjxlkcfz9zqak2vaw8nzvl39f")))
+        (origin
+          (method url-fetch)
+          (uri (string-append
+                "https://git.kernel.org/pub/scm/linux/kernel/git/arm64/linux.git"
+                "/patch/?id=c5157101e7793b42a56e07368c7f4cb73fb58008"))
+          (file-name "linux-libre-4.18-arm64-export-__sync_icache_dcache.patch")
+          (sha256
+           (base32 "0q13arsi8al3l3yq6d76z4h8n45wlpkjyxlrgn1sqbx5xjksycyz")))))
 
 (define-public linux-libre
   (make-linux-libre %linux-libre-version
                     %linux-libre-hash
                     %linux-compatible-systems
+                    #:patches %linux-libre-4.18-patches
                     #:configuration-file kernel-config))
 
-(define %linux-libre-4.14-version "4.14.62")
-(define %linux-libre-4.14-hash "0gpcdimig6d833dgxmj1i21dg8n12g4q38n0dq5j5x215w6rxy65")
+(define %linux-libre-4.14-version "4.14.65")
+(define %linux-libre-4.14-hash "0sdv2c0ix2mdc5h10d56bwi77hpb4gibmrsl1ydyb95hgg37k6h0")
 
 (define-public linux-libre-4.14
   (make-linux-libre %linux-libre-4.14-version
@@ -423,14 +445,14 @@ It has been modified to remove all non-free binary blobs.")
                     #:configuration-file kernel-config))
 
 (define-public linux-libre-4.9
-  (make-linux-libre "4.9.119"
-                    "1wqy9163w9srf614p57c3m7h8a2lbwv7f21m4cym397paqfkh4z4"
+  (make-linux-libre "4.9.122"
+                    "1yjld5q0xpsv4pd285hjp50kr2i41p3yiy1afp8nf88322i2947w"
                     %intel-compatible-systems
                     #:configuration-file kernel-config))
 
 (define-public linux-libre-4.4
-  (make-linux-libre "4.4.147"
-                    "0b9pr7qwa5ksj0bk5yh6hcxrjkv41ji0x29hscravmj4ckkxg0l6"
+  (make-linux-libre "4.4.150"
+                    "0dbz6bzxnr8dgp91lnf3jp42cw6dld4yq7ngigpq7s6ymr59j3ah"
                     %intel-compatible-systems
                     #:configuration-file kernel-config))
 
@@ -438,6 +460,7 @@ It has been modified to remove all non-free binary blobs.")
   (make-linux-libre %linux-libre-version
                     %linux-libre-hash
                     '("armhf-linux")
+                    #:patches %linux-libre-4.18-patches
                     #:defconfig "multi_v7_defconfig"
                     #:extra-version "arm-generic"))
 
@@ -452,6 +475,7 @@ It has been modified to remove all non-free binary blobs.")
   (make-linux-libre %linux-libre-version
                     %linux-libre-hash
                     '("armhf-linux")
+                    #:patches %linux-libre-4.18-patches
                     #:defconfig "omap2plus_defconfig"
                     #:extra-version "arm-omap2plus"))
 
@@ -539,15 +563,15 @@ at login.  Local and dynamic reconfiguration are its key features.")
 (define-public psmisc
   (package
     (name "psmisc")
-    (version "23.1")
+    (version "23.2")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "mirror://sourceforge/psmisc/psmisc/psmisc-"
+      (uri (string-append "mirror://sourceforge/psmisc/psmisc devel/psmisc-"
                           version ".tar.xz"))
       (sha256
        (base32
-        "0c5s94hqpwfmyswx2f96gifa6wdbpxxpkyxcrlzbxpvmrxsd911f"))))
+        "0s1kjhrik0wzqbm7hv4gkhywhjrwhp9ajw0ad05fwharikk6ah49"))))
     (build-system gnu-build-system)
     (inputs `(("ncurses" ,ncurses)))
     (home-page "https://gitlab.com/psmisc/psmisc")
@@ -738,7 +762,7 @@ slabtop, and skill.")
 (define-public e2fsprogs
   (package
     (name "e2fsprogs")
-    (version "1.43.6")
+    (version "1.44.3")
     (source (origin
              (method url-fetch)
              (uri (string-append
@@ -747,8 +771,7 @@ slabtop, and skill.")
                    name "-" version ".tar.xz"))
              (sha256
               (base32
-               "00ilv65dzcgiap435j89xk86shf7rrav3wsik7cahy789qijdcn9"))
-             (patches (search-patches "e2fsprogs-glibc-2.27.patch"))))
+               "1djb9qnid1j0vvna2bhq4jsz2ig1xckbx7h4d86cr0gl61yrz2ax"))))
     (build-system gnu-build-system)
     (inputs `(("util-linux" ,util-linux)))
     (native-inputs `(("pkg-config" ,pkg-config)
@@ -862,14 +885,16 @@ from the e2fsprogs package.  It is meant to be used in initrds.")
   (package
     (name "extundelete")
     (version "0.2.4")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://sourceforge/extundelete/"
-                                  "extundelete/" version "/extundelete-"
-                                  version ".tar.bz2"))
-              (sha256
-               (base32
-                "1x0r7ylxlp9lbj3d7sqf6j2a222dwy2nfpff05jd6mkh4ihxvyd1"))))
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/extundelete/"
+                           "extundelete/" version "/extundelete-"
+                           version ".tar.bz2"))
+       (sha256
+        (base32
+         "1x0r7ylxlp9lbj3d7sqf6j2a222dwy2nfpff05jd6mkh4ihxvyd1"))
+       (patches (search-patches "extundelete-e2fsprogs-1.44.patch"))))
     (build-system gnu-build-system)
     (inputs `(("e2fsprogs" ,e2fsprogs)))
     (home-page "http://extundelete.sourceforge.net/")
@@ -917,7 +942,7 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
 (define-public strace
   (package
     (name "strace")
-    (version "4.23")
+    (version "4.24")
     (home-page "https://strace.io")
     (source (origin
              (method url-fetch)
@@ -925,7 +950,7 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
                                  "/strace-" version ".tar.xz"))
              (sha256
               (base32
-               "1bcsq2gbpcb81ayryvn56a6kjx42fc21la6qgds35n0xbybacq3q"))))
+               "0d061cdzk6a1822ds4wpqxg10ny27mi4i9zjmnsbz8nz3vy5jkhz"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
@@ -934,7 +959,9 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
            (lambda _
              (substitute* "strace.c"
                (("/bin/sh") (which "sh")))
-             #t)))))
+             #t)))
+       ;; See <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32459>.
+       #:parallel-tests? #f))           ; undeterministic failures
     (native-inputs `(("perl" ,perl)))
     (synopsis "System call tracer for Linux")
     (description
@@ -2975,7 +3002,7 @@ arrays when needed.")
 (define-public multipath-tools
   (package
     (name "multipath-tools")
-    (version "0.7.6")
+    (version "0.7.7")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://git.opensvc.com/?p=multipath-tools/"
@@ -2983,7 +3010,7 @@ arrays when needed.")
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "0zkcayi3mmp43ji2zid1gprgsvqhjjapsw7jjd60sf75prf50h2r"))
+                "1lirhjjv37jnf42r1ylrhi8kbzx9j9xnyfzvxpp6bzcp0fawigig"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -2996,8 +3023,9 @@ arrays when needed.")
                   #t))))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f ; No tests.
-       #:make-flags (list (string-append "DESTDIR="
+     '(#:tests? #f                      ; no tests
+       #:make-flags (list "CC=gcc"
+                          (string-append "DESTDIR="
                                          (assoc-ref %outputs "out"))
                           "SYSTEMDPATH=lib"
                           (string-append "LDFLAGS=-Wl,-rpath="
@@ -3020,11 +3048,7 @@ arrays when needed.")
                  (("/usr/include/libudev.h")
                   (string-append udev "/include/libudev.h")))
                #t)))
-         (delete 'configure)
-         (add-before 'build 'set-CC
-           (lambda _
-             (setenv "CC" "gcc")
-             #t)))))
+         (delete 'configure))))
     (native-inputs
      `(("perl" ,perl)
        ("pkg-config" ,pkg-config)
@@ -3242,7 +3266,7 @@ and copy/paste text in the console and in xterm.")
 (define-public btrfs-progs
   (package
     (name "btrfs-progs")
-    (version "4.15.1")
+    (version "4.17.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://kernel.org/linux/kernel/"
@@ -3250,8 +3274,7 @@ and copy/paste text in the console and in xterm.")
                                   "btrfs-progs-v" version ".tar.xz"))
               (sha256
                (base32
-                "15izak6jg6pqr6ha9447cdrdj9k6kfiarvwlrj53cpvrsv02l437"))
-              (patches (search-patches "btrfs-progs-e-value-block.patch"))))
+                "0x6d53fbrcmzvhv461575fzsv3373427p4srz646w2wcagqk82xz"))))
     (build-system gnu-build-system)
     (outputs '("out"
                "static"))      ; static versions of the binaries in "out"
@@ -3287,6 +3310,7 @@ and copy/paste text in the console and in xterm.")
               ("zstd" ,zstd)))
     (native-inputs `(("pkg-config" ,pkg-config)
                      ("asciidoc" ,asciidoc)
+                     ("python" ,python)
                      ("xmlto" ,xmlto)
                      ;; For building documentation.
                      ("libxml2" ,libxml2)
@@ -3778,25 +3802,25 @@ native Linux file system, and has been part of the Linux kernel since version
 (define-public libnfsidmap
   (package
     (name "libnfsidmap")
-    (version "0.25")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append
-                   "http://www.citi.umich.edu/projects/nfsv4/linux/"
-                   name "/" name "-" version ".tar.gz"))
-             (sha256
-              (base32
-               "1kzgwxzh83qi97rblcm9qj80cdvnv8kml2plz0q103j0hifj8vb5"))))
+    (version "0.27")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://fedorapeople.org/~steved/"
+                           name "/" version "/" name "-" version ".tar.bz2"))
+       (sha256
+        (base32 "0bg2bcii424mf1bnp3fssr8jszbvhdxl7wvifm1yf6g596v8b8i5"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags (list
                           (string-append "--with-pluginpath="
                                          (assoc-ref %outputs "out")
                                          "/lib/libnfsidmap"))))
+    (native-inputs
+     `(("autoconf" ,autoconf)))         ; 0.27 still needs autoheader
     (home-page
      "http://www.citi.umich.edu/projects/nfsv4/crossrealm/libnfsidmap_config.html")
-    (synopsis
-     "NFSv4 support library for name/ID mapping")
+    (synopsis "NFSv4 support library for name/ID mapping")
     (description "Libnfsidmap is a library holding mulitiple methods of
 mapping names to ids and visa versa, mainly for NFSv4.  It provides an
 extensible array of mapping functions, currently consisting of two choices:
@@ -3983,7 +4007,7 @@ under OpenGL graphics workloads.")
     (version "35")
     (source (origin
               (method url-fetch)
-              (uri (string-append "https://github.com/rhinstaller/" name
+              (uri (string-append "https://github.com/rhboot/" name
                                   "/releases/download/" version "/" name
                                   "-" version ".tar.bz2"))
               (sha256
@@ -4004,7 +4028,7 @@ under OpenGL graphics workloads.")
      `(("pkg-config" ,pkg-config)))
     (inputs
      `(("popt" ,popt)))
-    (home-page "https://github.com/rhinstaller/efivar")
+    (home-page "https://github.com/rhboot/efivar")
     (synopsis "Tool and library to manipulate EFI variables")
     (description "This package provides a library and a command line
 interface to the variable facility of UEFI boot firmware.")