summary refs log tree commit diff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 89ccdb720a..9fb25a15a2 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -2382,19 +2382,17 @@ new fiends in addition to old friends like @command{aif} and
          (sha256
           (base32
            "127v5avpz1i4m0lkaxqrq8hrl69rdazqaxf6s8awf0nd7wj2g4dp"))
-         (file-name (git-file-name "lift" version))))
+         (file-name (git-file-name "lift" version))
+         (modules '((guix build utils)))
+         (snippet
+          ;; Don't keep the bundled website
+          `(begin
+             (delete-file-recursively "website")
+             #t))))
       (build-system asdf-build-system/sbcl)
       (arguments
        ;; The tests require a debugger, but we run with the debugger disabled.
-       '(#:tests? #f
-         #:phases
-         (modify-phases %standard-phases
-           ;; Do this to ensure the 'reset-gzip-timestamps phase works.
-           (add-after 'unpack 'make-gzips-writeable
-             (lambda _
-               (for-each (lambda (file)
-                           (chmod file #o755))
-                         (find-files "." "\\.gz$")))))))
+       '(#:tests? #f))
       (synopsis "LIsp Framework for Testing")
       (description
        "The LIsp Framework for Testing (LIFT) is a unit and system test tool for LISP.
@@ -2403,7 +2401,7 @@ testcases are organized into hierarchical testsuites each of which can have
 its own fixture.  When run, a testcase can succeed, fail, or error.  LIFT
 supports randomized testing, benchmarking, profiling, and reporting.")
       (home-page "https://github.com/gwkkwg/lift")
-      (license license:x11-style))))
+      (license license:expat))))
 
 (define-public cl-lift
   (sbcl-package->cl-source-package sbcl-lift))
@@ -2663,7 +2661,6 @@ pattern-matching-like, but a char-by-char procedural parser.")
        "This package exports the following function to parse floating-point
 values from a string in Common Lisp.")
       (home-page "https://github.com/soemraws/parse-float")
-      ;; TODO: Missing license?
       (license license:public-domain))))
 
 (define-public cl-parse-float