summary refs log tree commit diff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 0b7800734c..b6d52402a8 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -100,8 +100,10 @@ as \"x86_64-linux\"."
              ("i586"        => "X86"))))
 
 (define (llvm-uri component version)
+  ;; LLVM release candidate file names are formatted 'tool-A.B.C-rcN/tool-A.B.CrcN.src.tar.xz'
+  ;; so we specify the version as A.B.C-rcN and delete the hyphen when referencing the file name.
   (string-append "https://github.com/llvm/llvm-project/releases/download"
-                 "/llvmorg-" version "/" component "-" version ".src.tar.xz"))
+                 "/llvmorg-" version "/" component "-" (string-delete #\- version) ".src.tar.xz"))
 
 (define %llvm-release-monitoring-url
   "https://github.com/llvm/llvm-project/releases")
@@ -224,7 +226,7 @@ given PATCHES.  When TOOLS-EXTRA is given, it must point to the
                                 (invoke "tar" "xf" extra)
                                 (rename-file ,(string-append
                                                "clang-tools-extra-"
-                                               (package-version llvm)
+                                               (string-delete #\- (package-version llvm))
                                                ".src")
                                              "tools/extra")
                                 #t)))