summary refs log tree commit diff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm19
1 files changed, 1 insertions, 18 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index b3bd3b2276..178b92a0fb 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1510,24 +1510,7 @@ with that of libgomp, the GNU Offloading and Multi Processing Library.")
                               "expect-fastmath-entrypoints-in-add-TLI-mappings.ll.patch"
                               "0jxhjkkwwi1cy898l2n57l73ckpw0v73lqnrifp7r1mwpsh624nv")
                             ,@arch-independent-patches
-                            ,@(origin-patches (package-source llvm-11)))))))
-          (arguments
-           (substitute-keyword-arguments (package-arguments llvm-11)
-             ((#:phases phases)
-              `(modify-phases ,phases
-                 (add-after 'unpack 'patch-round-two
-                   ;; We have to do the patching in two rounds because we can't
-                   ;; pass '-p1' and '-p2' in the source field.
-                   (lambda* (#:key inputs #:allow-other-keys)
-                     (invoke "patch"
-                             (assoc-ref inputs "llvm_11_consecutive_registers")
-                             "-p2")))))))
-          (native-inputs
-           `(("llvm_11_consecutive_registers"
-              ,(patch-origin
-                "llvm_11_consecutive_registers.patch"
-                "04msd34dnpr3lpss0pam3mckwnvzrab266z6sml1hya0akv0m3f3"))
-             ,@(package-native-inputs llvm-11)))))))
+                            ,@(origin-patches (package-source llvm-11)))))))))))
     (home-page "https://llvmlite.pydata.org")
     (synopsis "Wrapper around basic LLVM functionality")
     (description