summary refs log tree commit diff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index ebea69eb9a..54d2ba400d 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -215,7 +215,7 @@ some projects.")))
      `(#:make-flags
        (let ((out (assoc-ref %outputs "out"))
              (lua-version ,(version-major+minor (package-version lua))))
-         (list "CC=gcc"
+         (list ,(string-append "CC=" (cc-for-target))
                (string-append "LUA_LDIR=" out "/share/lua/" lua-version)
                (string-append "LUA_CDIR=" out "/lib/lua/" lua-version)))
        #:phases
@@ -356,7 +356,7 @@ directory structure and file attributes.")
      `(#:make-flags
        (let ((out (assoc-ref %outputs "out"))
              (lua-api-version ,(version-major+minor (package-version lua))))
-         (list "CC=gcc"
+         (list ,(string-append "CC=" (cc-for-target))
                "CFLAGS='-D HAVE_SYS_SYSCTL_H=0'" ; sys/sysctl.h is deprecated
                (string-append "prefix=" out)
                (string-append "LUA_APIS=" lua-api-version)))
@@ -417,7 +417,7 @@ binds OpenSSL's bignum, message digest, HMAC, cipher, and CSPRNG interfaces.")
        (let ((out (assoc-ref %outputs "out"))
              (lua-version ,(version-major+minor (package-version lua))))
          (list "linux"
-               "CC=gcc"
+               ,(string-append "CC=" (cc-for-target))
                "LD=gcc"
                (string-append "LUAPATH=" out "/share/lua/" lua-version)
                (string-append "LUACPATH=" out "/lib/lua/" lua-version)))
@@ -465,7 +465,7 @@ secure session between the peers.")
        #:make-flags
        (let ((out (assoc-ref %outputs "out"))
              (lua-api-version ,(version-major+minor (package-version lua))))
-         (list "CC=gcc"
+         (list ,(string-append "CC=" (cc-for-target))
                (string-append "LUA_APIS=" lua-api-version)))
        #:phases
        (modify-phases %standard-phases
@@ -657,7 +657,7 @@ describing the commented declarations and functions.")
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags
-       (list "CC=gcc"
+       (list ,(string-append "CC=" (cc-for-target))
              (string-append "PREFIX=" (assoc-ref %outputs "out")))
        #:phases
        (modify-phases %standard-phases
@@ -1014,7 +1014,7 @@ on numbers.")
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f ;TODO: Run the test suite.
-       #:make-flags (list "CC=gcc"
+       #:make-flags (list ,(string-append "CC=" (cc-for-target))
                           (string-append "PREFIX=" %output))
        #:phases
        (modify-phases %standard-phases