summary refs log tree commit diff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 69180abeac..82ea6e02de 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -73,10 +73,10 @@
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
-               (zero? (system* "make" "install"
-                               (string-append "INSTALL_TOP=" out)
-                               (string-append "INSTALL_MAN=" out
-                                              "/share/man/man1")))))))))
+               (invoke "make" "install"
+                       (string-append "INSTALL_TOP=" out)
+                       (string-append "INSTALL_MAN=" out
+                                      "/share/man/man1"))))))))
     (home-page "https://www.lua.org/")
     (synopsis "Embeddable scripting language")
     (description
@@ -174,8 +174,8 @@ language.")
            (lambda _
              (setenv "LUA_CPATH" "src/?.so;;")
              (setenv "LUA_PATH"  "src/?.lua;;")
-             (and (zero? (system* "lua" "tests/test.lua"))
-                  (zero? (system* "lua" "tests/test-lom.lua"))))))))
+             (invoke "lua" "tests/test.lua")
+             (invoke "lua" "tests/test-lom.lua"))))))
     (inputs
      `(("lua" ,lua-5.1)
        ("expat" ,expat)))
@@ -210,8 +210,8 @@ language.")
              (setenv "LUA_CPATH" (string-append "src/?.so." ,version ";;"))
              (setenv "LUA_PATH"  "src/?.lua;;")
              (when (zero? (primitive-fork))
-               (system* "lua" "test/testsrvr.lua"))
-             (zero? (system* "lua" "test/testclnt.lua")))))))
+               (invoke "lua" "test/testsrvr.lua"))
+             (invoke "lua" "test/testclnt.lua"))))))
     (inputs
      `(("lua" ,lua-5.1)))
     (home-page "http://www.tecgraf.puc-rio.br/~diego/professional/luasocket/")