summary refs log tree commit diff
path: root/gnu/packages/lxde.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lxde.scm')
-rw-r--r--gnu/packages/lxde.scm45
1 files changed, 23 insertions, 22 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 14c4120d05..fbf32bf337 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -4,7 +4,7 @@
 ;;; Copyright © 2017 Nikita <nikita@n0.is>
 ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2017 Brendan Tildesley <mail@brendan.scot>
-;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 ison <ison@airmail.cc>
 ;;; Copyright © 2018, 2019 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
@@ -31,6 +31,7 @@
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bash)
+  #:use-module (gnu packages curl)
   #:use-module (gnu packages disk)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages file-systems)
@@ -104,14 +105,14 @@ libFM file management library.")))
 (define-public lxappearance
   (package
     (name "lxappearance")
-    (version "0.6.2")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://sourceforge/lxde/"
-                                  "LXAppearance/" name "-" version ".tar.xz"))
-              (sha256
-               (base32
-                "07r0xbi6504zjnbpan7zrn7gi4j0kbsqqfpj8v2x94gr05p16qj4"))))
+    (version "0.6.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/lxde/"
+                           "LXAppearance/lxappearance-" version ".tar.xz"))
+       (sha256
+        (base32 "0f4bjaamfxxdr9civvy55pa6vv9dx1hjs522gjbbgx7yp1cdh8kj"))))
     (build-system gnu-build-system)
     (inputs `(("gtk+" ,gtk+-2)))
     (native-inputs `(("intltool"   ,intltool)
@@ -125,16 +126,16 @@ able to change themes, icons, and fonts used by GTK+ applications.")
 (define-public lxrandr
   (package
     (name "lxrandr")
-    (version "0.3.1")
+    (version "0.3.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/lxde/LXRandR"
                                   "%20%28monitor%20config%20tool%29/LXRandR%20"
                                   (version-major+minor version) ".x/"
-                                  name "-" version ".tar.xz"))
+                                  "lxrandr-" version ".tar.xz"))
               (sha256
                (base32
-                "0khqi42paqg82jllb2kza4arf3fafzgq90fhyr3rw3d9hn23763d"))))
+                "04n3vgh3ix12p8jfs4w0dyfq3anbjy33h7g53wbbqqc0f74xyplb"))))
     (build-system gnu-build-system)
     (inputs `(("gtk+" ,gtk+-2)))
     (native-inputs `(("intltool"   ,intltool)
@@ -518,16 +519,14 @@ in LXDE.")
 (define-public lxsession
   (package
     (name "lxsession")
-    (version "0.5.3")
+    (version "0.5.5")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://downloads.sourceforge.net/lxde/"
-                           name "-" version ".tar.xz"))
-       (patches (search-patches "lxsession-use-gapplication.patch"))
+                           "lxsession-" version ".tar.xz"))
        (sha256
-        (base32
-         "1a0zmyywwzdh59nc0l94cir18vhp633z4q2xfhn5zx11ajj45gwh"))
+        (base32 "0imv9nysip1j9lrb2z96kl05isjgp312323wnnd5b59h0ff0sgp4"))
        (modules '((guix build utils)))
        (snippet
         ;; Remove C files generated by Vala so we can build from source.
@@ -560,6 +559,8 @@ in LXDE.")
        ("intltool" ,intltool)
        ("docbook-xsl" ,docbook-xsl)
        ("vala" ,vala)
+
+       ;; For bootstrapping.
        ("autoconf" ,autoconf)
        ("automake" ,automake)))
     (synopsis "Lightweight X11 session manager")
@@ -571,15 +572,14 @@ in LXDE.")
 (define-public lxpanel
   (package
     (name "lxpanel")
-    (version "0.9.3")
+    (version "0.10.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://downloads.sourceforge.net/lxde/"
-                           name "-" version ".tar.xz"))
+                           "lxpanel-" version ".tar.xz"))
        (sha256
-        (base32
-         "1ccgv7jgl3y865cpb6w7baaz7468fxncm83bqxlwyni5bwhglb1l"))))
+        (base32 "0zis3b815p375s6mymhf5sn1a0c1xv0ixxzb0mh3fqhrby6cqy26"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
@@ -594,7 +594,8 @@ in LXDE.")
                #t))))))
     (inputs
      ;; TODO: libindicator-0.3.0
-     `(("gtk+-2" ,gtk+-2)
+     `(("curl" ,curl)
+       ("gtk+-2" ,gtk+-2)
        ("alsa-lib" ,alsa-lib)
        ("libwnck-2" ,libwnck-2)
        ("keybinder" ,keybinder)