summary refs log tree commit diff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm56
1 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index b4cdcaac0f..c797b63754 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -90,7 +90,7 @@
     (native-inputs
      `(("doxygen" ,doxygen)))
     (inputs
-     `(("qtbase" ,qtbase)))
+     `(("qtbase" ,qtbase-5)))
     (home-page "https://launchpad.net/libdbusmenu-qt")
     (synopsis "Qt implementation of the DBusMenu spec")
     (description "This library provides a Qt implementation of the DBusMenu
@@ -150,7 +150,7 @@ to statistics about the system on which it's run.")
      `(("pkg-config" ,pkg-config)
        ("glib" ,glib)))
     (inputs
-     `(("qtbase" ,qtbase)))
+     `(("qtbase" ,qtbase-5)))
     (propagated-inputs
      ;; Dependent projects require Perl via the CMake files.
      `(("perl" ,perl)))
@@ -188,7 +188,7 @@ itself as well as other components maintained by the LXQt project.")
     (propagated-inputs
      ;; required by Qt5XdgIconLoader.pc
      `(("glib" ,glib)
-       ("qtbase" ,qtbase)
+       ("qtbase" ,qtbase-5)
        ("qtsvg" ,qtsvg)))
     (native-inputs
      `(("lxqt-build-tools" ,lxqt-build-tools)
@@ -259,7 +259,7 @@ components of the LXQt desktop environment.")
     (build-system cmake-build-system)
     (arguments '(#:tests? #f))          ; no tests
     (inputs
-     `(("qtbase" ,qtbase)))
+     `(("qtbase" ,qtbase-5)))
     (native-inputs
      `(("lxqt-build-tools" ,lxqt-build-tools)))
     (home-page "https://lxqt-project.org")
@@ -287,7 +287,7 @@ and memory usage or network traffic.")
      `(("kwindowsystem" ,kwindowsystem)
        ("liblxqt" ,liblxqt)
        ("libqtxdg" ,libqtxdg)
-       ("qtbase" ,qtbase)
+       ("qtbase" ,qtbase-5)
        ("qtsvg" ,qtsvg)
        ("qtx11extras" ,qtx11extras)))
     (native-inputs
@@ -380,7 +380,7 @@ the operating system LXQt is running on.")
        ("libqtxdg" ,libqtxdg)
        ("libxcursor" ,libxcursor)
        ("libxi" ,libxi)
-       ("qtbase" ,qtbase)
+       ("qtbase" ,qtbase-5)
        ("qtsvg" ,qtsvg)
        ("qtx11extras" ,qtx11extras)
        ("solid" ,solid)
@@ -450,7 +450,7 @@ configuration of both LXQt and the underlying operating system.")
      `(("kwindowsystem" ,kwindowsystem)
        ("liblxqt" ,liblxqt)
        ("libqtxdg" ,libqtxdg)
-       ("qtbase" ,qtbase)
+       ("qtbase" ,qtbase-5)
        ("qtsvg" ,qtsvg)
        ("qtx11extras" ,qtx11extras)))
     (native-inputs
@@ -498,7 +498,7 @@ as a whole and are not limited to distinct applications.")
      `(("kwindowsystem" ,kwindowsystem)
        ("liblxqt" ,liblxqt)
        ("libqtxdg" ,libqtxdg)
-       ("qtbase" ,qtbase)
+       ("qtbase" ,qtbase-5)
        ("qtsvg" ,qtsvg)
        ("qtx11extras" ,qtx11extras)))
     (native-inputs
@@ -544,7 +544,7 @@ according to the Desktop Notifications Specification.")
      `(("kwindowsystem" ,kwindowsystem)
        ("liblxqt" ,liblxqt)
        ("libqtxdg" ,libqtxdg)
-       ("qtbase" ,qtbase)
+       ("qtbase" ,qtbase-5)
        ("qtsvg" ,qtsvg)
        ("qtx11extras" ,qtx11extras)))
     (native-inputs
@@ -595,7 +595,7 @@ of other programs.")
        ("lxqt-globalkeys" ,lxqt-globalkeys)
        ("pcre" ,pcre)
        ("pulseaudio" ,pulseaudio)
-       ("qtbase" ,qtbase)
+       ("qtbase" ,qtbase-5)
        ("qtsvg" ,qtsvg)
        ("qtx11extras" ,qtx11extras)
        ("solid" ,solid)
@@ -660,7 +660,7 @@ of other programs.")
        ("libqtxdg" ,libqtxdg)
        ("pcre" ,pcre)
        ("polkit-qt" ,polkit-qt)
-       ("qtbase" ,qtbase)
+       ("qtbase" ,qtbase-5)
        ("qtsvg" ,qtsvg)
        ("qtx11extras" ,qtx11extras)))
     (native-inputs
@@ -709,7 +709,7 @@ LXQt.")
        ("liblxqt" ,liblxqt)
        ("libqtxdg" ,libqtxdg)
        ("lxqt-globalkeys" ,lxqt-globalkeys)
-       ("qtbase" ,qtbase)
+       ("qtbase" ,qtbase-5)
        ("qtsvg" ,qtsvg)
        ("qtx11extras" ,qtx11extras)
        ("solid" ,solid)))
@@ -757,7 +757,7 @@ when laptop batteries are low on power.")
      `(("libdbusmenu-qt" ,libdbusmenu-qt)
        ("libfm-qt" ,libfm-qt)
        ("libqtxdg" ,libqtxdg)
-       ("qtbase" ,qtbase)
+       ("qtbase" ,qtbase-5)
        ("qtsvg" ,qtsvg)
        ("qtx11extras" ,qtx11extras)))
     (native-inputs
@@ -798,7 +798,7 @@ Qt with LXQt.")
        ("lxqt-globalkeys" ,lxqt-globalkeys)
        ("muparser" ,muparser)
        ("pcre" ,pcre)
-       ("qtbase" ,qtbase)
+       ("qtbase" ,qtbase-5)
        ("qtsvg" ,qtsvg)
        ("qtx11extras" ,qtx11extras)))
     (native-inputs
@@ -846,7 +846,7 @@ allows for launching applications or shutting down the system.")
        ("liblxqt" ,liblxqt)
        ("libqtxdg" ,libqtxdg)
        ("procps" ,procps)
-       ("qtbase" ,qtbase)
+       ("qtbase" ,qtbase-5)
        ("qtsvg" ,qtsvg)
        ("qtx11extras" ,qtx11extras)
        ("xdg-user-dirs" ,xdg-user-dirs)))
@@ -916,7 +916,7 @@ for the LXQt desktop environment.")
      `(("kwindowsystem" ,kwindowsystem)
        ("liblxqt" ,liblxqt)
        ("libqtxdg" ,libqtxdg)
-       ("qtbase" ,qtbase)
+       ("qtbase" ,qtbase-5)
        ("qtsvg" ,qtsvg)
        ("qtx11extras" ,qtx11extras)
        ("sudo" ,sudo)))
@@ -1001,7 +1001,7 @@ for LXQt.")
        ("libxcb" ,libxcb)
        ("menu-cache" ,menu-cache)
        ("pcre" ,pcre)
-       ("qtbase" ,qtbase)
+       ("qtbase" ,qtbase-5)
        ("qtx11extras" ,qtx11extras)))
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -1027,7 +1027,7 @@ components to build desktop file managers which belongs to LXDE.")
     (build-system cmake-build-system)
     (inputs
      `(("libfm-qt" ,libfm-qt)
-       ("qtbase" ,qtbase)
+       ("qtbase" ,qtbase-5)
        ("qtx11extras" ,qtx11extras)))
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -1069,7 +1069,7 @@ LXDE.")
     (build-system cmake-build-system)
     (inputs
      `(("libconfig" ,libconfig)
-       ("qtbase" ,qtbase)))
+       ("qtbase" ,qtbase-5)))
     (native-inputs
      `(("lxqt-build-tools" ,lxqt-build-tools)
        ("pkg-config" ,pkg-config)
@@ -1105,7 +1105,7 @@ manager Compton.")
     (inputs
      `(("libexif" ,libexif)
        ("libfm-qt" ,libfm-qt)
-       ("qtbase" ,qtbase)
+       ("qtbase" ,qtbase-5)
        ("qtsvg" ,qtsvg)
        ("qtx11extras" ,qtx11extras)))
     (native-inputs
@@ -1141,7 +1141,7 @@ image viewer.")
        ("openbox" ,openbox)
        ("pango" ,pango)
        ("pcre" ,pcre)
-       ("qtbase" ,qtbase)
+       ("qtbase" ,qtbase-5)
        ("qtx11extras" ,qtx11extras)))
     (native-inputs
      `(("lxqt-build-tools" ,lxqt-build-tools)
@@ -1171,7 +1171,7 @@ window manager OpenBox.")
      `(("glib" ,glib)
        ("pcre" ,pcre)
        ("pulseaudio" ,pulseaudio)
-       ("qtbase" ,qtbase)
+       ("qtbase" ,qtbase-5)
        ("qtx11extras" ,qtx11extras)))
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -1202,7 +1202,7 @@ window manager OpenBox.")
        ("libxrender" ,libxrender)
        ("liblxqt" ,liblxqt)
        ("libqtxdg" ,libqtxdg)
-       ("qtbase" ,qtbase)
+       ("qtbase" ,qtbase-5)
        ("qtx11extras" ,qtx11extras)))
     (native-inputs
      `(("lxqt-build-tools" ,lxqt-build-tools)
@@ -1228,7 +1228,7 @@ processes currently in existence, much like code{top} or code{ps}.")
         (base32 "10lv475qj0x3c3vl4yhjyr6y10qj5pq8n5pal5k24f6pf7xv412f"))))
     (build-system cmake-build-system)
     (inputs
-     `(("qtbase" ,qtbase)
+     `(("qtbase" ,qtbase-5)
        ("utf8proc" ,utf8proc)))
     (native-inputs
      `(("lxqt-build-tools" ,lxqt-build-tools)
@@ -1253,7 +1253,7 @@ processes currently in existence, much like code{top} or code{ps}.")
         (base32 "0rfv7a6ncm8fs8aicinh9l29w4636gxzcqz735jmch2r41v9i1d9"))))
     (build-system cmake-build-system)
     (inputs
-     `(("qtbase" ,qtbase)
+     `(("qtbase" ,qtbase-5)
        ("qtx11extras" ,qtx11extras)
        ("qtermwidget" ,qtermwidget)))
     (native-inputs
@@ -1282,7 +1282,7 @@ QTermWidget.")
     (inputs
      `(("kwindowsystem" ,kwindowsystem)
        ("libqtxdg" ,libqtxdg)
-       ("qtbase" ,qtbase)
+       ("qtbase" ,qtbase-5)
        ("qtsvg" ,qtsvg)
        ("qtx11extras" ,qtx11extras)))
     (native-inputs
@@ -1314,7 +1314,7 @@ easily publishing them on internet image hosting services.")
       `(("glib" ,glib)
         ("json-glib" ,json-glib)
         ("libfm-qt" ,libfm-qt)
-        ("qtbase" ,qtbase)
+        ("qtbase" ,qtbase-5)
         ("qtx11extras" ,qtx11extras)))
     (native-inputs
       `(("pkg-config" ,pkg-config)
@@ -1349,7 +1349,7 @@ like @command{tar} and @command{zip}.")
       (build-system cmake-build-system)
       (inputs
         `(("kwindowsystem" ,kwindowsystem)
-          ("qtbase" ,qtbase)
+          ("qtbase" ,qtbase-5)
           ("qtsvg" ,qtsvg)
           ("liblxqt" ,liblxqt)
           ("qtx11extras" ,qtx11extras)