summary refs log tree commit diff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 5c1497bd92..3bb09129f5 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1011,6 +1011,28 @@ data analysis.")
                 (sha256
                  (base32
                   "08zbzi8yx5wdlxfx9jap61vg1malc9ajf576w7a0liv6jvvrxlpj"))))
+      (arguments
+       `(#:python ,python-2
+         #:phases
+         (modify-phases %standard-phases
+           (add-after 'build 'build-ext
+             (lambda _ (invoke "python" "setup.py" "build_ext" "--inplace")))
+           (replace 'check
+             (lambda* (#:key tests? #:allow-other-keys)
+               (when tests?
+                 ;; Restrict OpenBLAS threads to prevent segfaults while testing!
+                 (setenv "OPENBLAS_NUM_THREADS" "1")
+
+                 ;; Some tests require write access to $HOME.
+                 (setenv "HOME" "/tmp")
+
+                 (invoke "pytest" "sklearn" "-m" "not network"
+                         "-k"
+                         (string-append
+                          ;; This test tries to access the internet.
+                          "not test_load_boston_alternative"
+                          ;; This test fails for unknown reasons
+                          " and not test_rank_deficient_design"))))))))
       (inputs
        `(("openblas" ,openblas)))
       (native-inputs