summary refs log tree commit diff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm122
1 files changed, 64 insertions, 58 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 80e2ce2a9b..6ef4c6fdab 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -51,6 +51,7 @@
 ;;; Copyright © 2022 muradm <mail@muradm.net>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;; Copyright © 2022 ( <paren@disroot.org>
+;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1111,55 +1112,58 @@ repository and Maildir/IMAP as LOCAL repository.")
   (deprecated-package "offlineimap" offlineimap3))
 
 (define-public emacs-mew
-  (package
-    (name "emacs-mew")
-    (version "6.8")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://mew.org/Release/mew-"
-                                  version ".tar.gz"))
-              (sha256
-               (base32
-                "0ixzyq33l6j34410kqav3lwn2wx171zvqd3irvns2jvhrbww8i6g"))))
-    (native-inputs
-     (list emacs))
-    (propagated-inputs
-     (list ruby-sqlite3 ; optional for the database of messages
-           ruby)) ; to set GEM_PATH so ruby-sqlite3 is found at runtime
-    (build-system gnu-build-system)
-    (arguments
-     (let ((elisp-dir "/share/emacs/site-lisp")
-           (icon-dir  "/share/mew"))
-       `(#:modules ((guix build gnu-build-system)
-                    (guix build utils)
-                    (guix build emacs-utils))
-         #:imported-modules (,@%gnu-build-system-modules
-                             (guix build emacs-utils))
-         #:configure-flags
-         (list (string-append "--with-elispdir=" %output ,elisp-dir)
-               (string-append "--with-etcdir=" %output ,icon-dir))
-         #:phases
-         (modify-phases %standard-phases
-           (add-after 'configure 'patch-mew-icon-directory
-             (lambda* (#:key outputs #:allow-other-keys)
-               (emacs-substitute-sexps "mew-key.el"
-                 ("(def.* mew-icon-directory"
-                  `(progn
-                    (add-to-list 'image-load-path 'mew-icon-directory)
-                    ,(string-append (assoc-ref outputs "out") ,icon-dir))))
-               #t))
-           (add-after 'install 'generate-autoloads
-             (lambda* (#:key outputs #:allow-other-keys)
-               (emacs-generate-autoloads
-                "mew" (string-append (assoc-ref outputs "out") ,elisp-dir))
-               #t)))
-         #:tests? #f)))
-    (home-page "https://mew.org")
-    (synopsis "Emacs e-mail client")
-    (description "Mew (Messaging in the Emacs World) is a user interface
+  (let ((commit "35772ee0b44dd7e56b0f3899b27fa545b2bc6f03")
+        (revision "1"))
+    (package
+      (name "emacs-mew")
+      (version (git-version "6.9" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/kazu-yamamoto/Mew")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0xazygwdc328m5l31rxjazq9giv2xrygp2p2q455lf3jhdxwq1km"))))
+      (build-system gnu-build-system)
+      (arguments
+       (let ((elisp-dir #~(string-append #$output "/share/emacs/site-lisp"))
+             (icon-dir  #~(string-append #$output "/share/mew")))
+         (list
+          #:modules '((guix build gnu-build-system)
+                      (guix build utils)
+                      (guix build emacs-utils))
+          #:imported-modules `(,@%gnu-build-system-modules
+                               (guix build emacs-utils))
+          #:tests? #f
+          #:configure-flags
+          #~(list (string-append "--with-elispdir=" #$elisp-dir)
+                  (string-append "--with-etcdir=" #$icon-dir))
+          #:phases
+          #~(modify-phases %standard-phases
+              (add-after 'configure 'patch-mew-icon-directory
+                (lambda _
+                  (emacs-substitute-sexps "elisp/mew-key.el"
+                    ("(def.* mew-icon-directory"
+                     `(progn
+                       (add-to-list 'image-load-path 'mew-icon-directory)
+                       ,#$icon-dir)))))
+              (add-after 'install 'generate-autoloads
+                (lambda _
+                  (emacs-generate-autoloads "mew" #$elisp-dir)))))))
+      (native-inputs
+       (list emacs))
+      (propagated-inputs
+       (list ruby        ; to set GEM_PATH so ruby-sqlite3 is found at runtime
+             ruby-sqlite3))            ; optional for the database of messages
+      (home-page "https://mew.org")
+      (synopsis "Emacs e-mail client")
+      (description "Mew (Messaging in the Emacs World) is a user interface
 for text messages, multimedia messages (MIME), news articles and
 security functionality including PGP, S/MIME, SSH, and SSL.")
-    (license license:bsd-3)))
+      (license license:bsd-3))))
 
 (define-public mu
   (package
@@ -1598,7 +1602,7 @@ system, written in the Mercury language.")
      (list pandoc pkg-config))
     (inputs
      (list openssl notmuch sqlite xapian))
-    (home-page "http://www.muchsync.org/")
+    (home-page "https://www.muchsync.org/")
     (synopsis "Synchronize notmuch mail across machines")
     (description
      "Muchsync brings Notmuch to all of your computers by synchronizing your
@@ -1795,14 +1799,14 @@ addons which can add many functionalities to the base client.")
 (define-public msmtp
   (package
     (name "msmtp")
-    (version "1.8.22")
+    (version "1.8.23")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://marlam.de/msmtp/releases"
                            "/msmtp-" version ".tar.xz"))
        (sha256
-        (base32 "1rx3ksvwdfrwahsd2lwf52vnhhq72ygb0kjy6ci2df55hri2010v"))))
+        (base32 "1f2nqdj3k8q7l4m3a6n8ckaslilxxp2kzfdmni6l2gcv15mw216g"))))
     (build-system gnu-build-system)
     (inputs
      (list libsecret gnutls zlib gsasl))
@@ -2551,7 +2555,7 @@ separation to safely deliver mail in multi-user setups.")
     ;; are performed before the actual build process.
     (build-system gnu-build-system)
     (inputs (list exim))
-    (home-page "http://www.procmail.org/")
+    (home-page "https://www.procmail.org/")
     (synopsis "Versatile mail delivery agent (MDA)")
     (description "Procmail is a mail delivery agent (MDA) featuring support
 for a variety of mailbox formats such as mbox, mh and maildir.  Incoming mail
@@ -2891,20 +2895,22 @@ easily (one at a time).")
 (define-public mpop
   (package
     (name "mpop")
-    (version "1.4.17")
+    (version "1.4.18")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://marlam.de/mpop/releases/"
                            "mpop-" version ".tar.xz"))
        (sha256
-        (base32 "1mcbvzdbdr86zsq8zr1zryjrmfiqikckx3648zvdjh99mm5lkbj2"))))
+        (base32 "1dw5kwflga26kfjl999lilq14vvk6fcapryihakr9l7phh0rb6b0"))))
     (build-system gnu-build-system)
     (inputs
      (list gnutls))
     (native-inputs
      (list pkg-config))
     (home-page "https://marlam.de/mpop/")
+    (properties
+     '((release-monitoring-url . "https://marlam.de/mpop/download/")))
     (synopsis "POP3 mail client")
     (description "mpop is a small and fast POP3 client suitable as a
 fetchmail replacement.
@@ -3035,7 +3041,7 @@ define(`confINST_DEP', `')
        #:tests? #f))
     (inputs
      (list m4 perl))
-    (home-page "http://sendmail.org")
+    (home-page "https://sendmail.org")
     (synopsis
      "Highly configurable Mail Transfer Agent (MTA)")
     (description
@@ -3325,7 +3331,7 @@ writing OpenSMTPd filters.")
            ;; Our OpenSMTPd package uses libressl, but this package currently
            ;; supports HAVE_ED25519 only with openssl.
            openssl))
-    (home-page "http://imperialat.at/dev/filter-dkimsign/")
+    (home-page "https://imperialat.at/dev/filter-dkimsign/")
     (synopsis "OpenSMTPd filter for signing mail with DKIM")
     (description
      "The @command{filter-dkimsign} OpenSMTPd filter signs outgoing e-mail
@@ -4670,7 +4676,7 @@ ex-like commands on it.")
      (list tre))
     (native-inputs
      `(("emacs" ,emacs-minimal)))
-    (home-page "http://crm114.sourceforge.net/")
+    (home-page "https://crm114.sourceforge.net/")
     (synopsis "Controllable regex mutilator")
     (description "CRM114 is a system to examine incoming e-mail, system log
 streams, data files or other data streams, and to sort, filter, or alter the
@@ -4786,7 +4792,7 @@ remote SMTP server.")
 (define-public aerc
   (package
     (name "aerc")
-    (version "0.13.0")
+    (version "0.14.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -4795,7 +4801,7 @@ remote SMTP server.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "18rykklc0ppl53sm9lzhrw6kv4rcc7x45nv7qii7m4qads2pyjm5"))))
+                "067j7kja78hv7dafw8gy3m2g5cslq6xlnzja8lm3b5p0m0vfabm8"))))
     (build-system go-build-system)
     (arguments
      (list #:import-path "git.sr.ht/~rjarry/aerc"