summary refs log tree commit diff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index a2af7c7f97..526e63829d 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -367,7 +367,16 @@ repository and Maildir/IMAP as LOCAL repository.")
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'autoreconf
+         (add-after 'unpack 'patch-configure.ac
+           ;; By default, elisp code goes to "share/emacs/site-lisp/mu4e",
+           ;; so our Emacs package can't find it.  Setting "--with-lispdir"
+           ;; configure flag doesn't help because "mu4e" will be added to
+           ;; the lispdir anyway, so we have to modify "configure.ac".
+           (lambda _
+             (substitute* "configure.ac"
+               (("^ +lispdir=.*") ""))
+             #t))
+         (add-after 'patch-configure.ac 'autoreconf
            (lambda _
              (zero? (system* "autoreconf" "-vi"))))
          (add-before 'check 'check-tz-setup