summary refs log tree commit diff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 9b16f37031..c8de969b1a 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -410,13 +410,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
   ;; A statically-linked Guile that is relocatable--i.e., it can search
   ;; .scm and .go files relative to its installation directory, rather
   ;; than in hard-coded configure-time paths.
-  (let* ((libgc (package (inherit libgc)
-		  (arguments
-		   ;; Make it so that we don't rely on /proc.  This is
-		   ;; especially useful in an initrd run before /proc is
-		   ;; mounted.
-		   '(#:configure-flags '("CPPFLAGS=-DUSE_LIBC_PRIVATES")))))
-	 (guile (package (inherit guile-2.0)
+  (let* ((guile (package (inherit guile-2.0)
 		  (name (string-append (package-name guile-2.0) "-static"))
 		  (inputs
 		   `(("patch/relocatable"