summary refs log tree commit diff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm30
1 files changed, 21 insertions, 9 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 50796df89e..813ef46e62 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -269,7 +269,7 @@ PostScript, and PDF.  Additional tools include the @command{man} viewer, and
 (define-public man-pages
   (package
     (name "man-pages")
-    (version "5.13")
+    (version "6.00")
     (source
      (origin
        (method url-fetch)
@@ -279,18 +279,30 @@ PostScript, and PDF.  Additional tools include the @command{man} viewer, and
               (string-append "mirror://kernel.org/linux/docs/man-pages/Archive/"
                              "man-pages-" version ".tar.xz")))
        (sha256
-        (base32 "12vb15gs56g8wl5nqlm4llr508brh4m2lfknhq4lizbxzqzawkb1"))))
+        (base32 "1252c1356z5spya3yl0lcmmymglx3bmfwmamiz1y5l13xqpwbnwy"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases (modify-phases %standard-phases (delete 'configure))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'skip-html
+            ;; As of 6.00, this package tries to convert man pages to HTML with
+            ;; man2html.  The only Guix package currently providing that script
+            ;; is man-for-txr, but that version seems unable to handle relative
+            ;; ‘.so’ statements properly.  Disable HTML generation.
+            (lambda _
+              (substitute* "lib/build-html.mk"
+                (("(html:) .*" _ target) (string-append target "\n")))))
+          (delete 'configure))
 
-       ;; The 'all' target depends on three targets that directly populate
-       ;; $(MANDIR) based on its current contents.  Doing that in parallel
-       ;; leads to undefined behavior (see <http://bugs.gnu.org/18701>.)
-       #:parallel-build? #f
+      ;; The 'all' target depends on three targets that directly populate
+      ;; $(MANDIR) based on its current contents.  Doing that in parallel
+      ;; leads to undefined behavior (see <http://bugs.gnu.org/18701>.)
+      #:parallel-build? #f
 
-       #:tests? #f
-       #:make-flags ,#~(list (string-append "mandir=" #$output "/share/man"))))
+      #:tests? #f
+      #:make-flags
+      #~(list (string-append "mandir=" #$output "/share/man"))))
     (home-page "https://www.kernel.org/doc/man-pages/")
     (synopsis "Development manual pages from the Linux project")
     (description