summary refs log tree commit diff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm56
1 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 8565031571..1aa0b7ef8f 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -6,7 +6,7 @@
 ;;; Copyright © 2015, 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017–2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018, 2019, 2022 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
@@ -127,14 +127,14 @@ a flexible and convenient way.")
 (define-public man-db
   (package
     (name "man-db")
-    (version "2.10.2")
+    (version "2.11.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://savannah/man-db/man-db-"
                                   version ".tar.xz"))
               (sha256
                (base32
-                "0kaiymd5lh4dnp6z15fnvfg0ir81kdxp5l690ccp64ra956rb5zf"))))
+                "1k5nhy2c33k0p2f1sbb4hxpwrjw6v4scchwykkg4g61la59amarf"))))
     (build-system gnu-build-system)
     (arguments
      (list #:phases
@@ -352,36 +352,36 @@ on any distribution, and the nroff source is included."))))
   ;; input "locales" contain the original (English) text.
   (package
     (name "help2man")
-    (version "1.48.5")
+    (version "1.49.2")
     (source
      (origin
-      (method url-fetch)
-      (uri (string-append "mirror://gnu/help2man/help2man-"
-                          version ".tar.xz"))
-      (sha256
-       (base32
-        "1gl24n9am3ivhql1gs9lffb415irg758fhxyk4ryssiflk5f8fb7"))))
+       (method url-fetch)
+       (uri (string-append "mirror://gnu/help2man/help2man-"
+                           version ".tar.xz"))
+       (sha256
+        (base32
+         "0dnxx96lbcb8ab8yrdkqll14cl5n0bch8qpd9qj3c2ky78hhwbly"))))
     (build-system gnu-build-system)
-    (arguments `(;; There's no `check' target.
-                 #:tests? #f
-                 #:phases
-                 (modify-phases %standard-phases
-                   (add-after 'unpack 'patch-help2man-with-perl-gettext
-                     (lambda* (#:key inputs #:allow-other-keys)
-                       (let ((lib (assoc-ref inputs "perl-gettext"))
-                             (fmt "use lib '~a/lib/perl5/site_perl';~%~a"))
-                         (substitute* "help2man.PL"
-                           (("^use Locale::gettext.*$" load)
-                            (format #f fmt lib load))))
-                       #t)))))
+    (arguments
+     (list
+      #:tests? #f                       ;no `check' target
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-help2man-with-perl-gettext
+            (lambda* (#:key inputs #:allow-other-keys)
+              (let ((lib #$(this-package-input "perl-gettext"))
+                    (fmt "use lib '~a/lib/perl5/site_perl';~%~a"))
+                (substitute* "help2man.PL"
+                  (("^use Locale::gettext.*$" load)
+                   (format #f fmt lib load)))))))))
     (inputs
-     `(("perl" ,perl)
-       ,@(if (%current-target-system)
-             '()
-             `(("perl-gettext" ,perl-gettext)))))
+     (append
+      (list perl)
+      (if (%current-target-system)
+          '()
+          (list perl-gettext))))
     (native-inputs
-     `(("perl" ,perl)
-       ("gettext" ,gettext-minimal)))
+     (list perl gettext-minimal))
     (home-page "https://www.gnu.org/software/help2man/")
     (synopsis "Automatically generate man pages from program --help")
     (description