summary refs log tree commit diff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm730
1 files changed, 341 insertions, 389 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 82b2d6e0fd..dd6baa42b6 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
 ;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
 ;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -106,23 +107,23 @@ MATE applications.")
         (base32 "0fni41p3kraxwjnx9l5mdspng0zib1gfdxwlaiyq31mh4g79yjyj"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("yelp-tools" ,yelp-tools)
-       ("gettext" ,gettext-minimal)
-       ("glib" ,glib "bin") ; glib-gettextize
-       ("polkit" ,polkit))) ; for ITS rules
+     (list pkg-config
+           yelp-tools
+           gettext-minimal
+           `(,glib "bin") ; glib-gettextize
+           polkit)) ; for ITS rules
     (inputs
-     `(("gtk+" ,gtk+)
-       ("glib" ,glib)
-       ("dbus-glib" ,dbus-glib)
-       ("libgnome-keyring" ,libgnome-keyring)
-       ("cairo" ,cairo)
-       ("dbus" ,dbus)
-       ("libnotify" ,libnotify)
-       ("mate-panel" ,mate-panel)
-       ("libxrandr" ,libxrandr)
-       ("libcanberra" ,libcanberra)
-       ("upower" ,upower)))
+     (list gtk+
+           glib
+           dbus-glib
+           libgnome-keyring
+           cairo
+           dbus
+           libnotify
+           mate-panel
+           libxrandr
+           libcanberra
+           upower))
     (home-page "https://mate-desktop.org/")
     (synopsis "Power manager for MATE")
     (description
@@ -145,9 +146,7 @@ actions.")
          "0a2lz61ivwwcdznmwlmgjr6ipr9sdl5g2czbagnpxkwz8f3m77na"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("intltool" ,intltool)
-       ("icon-naming-utils" ,icon-naming-utils)))
+     (list pkg-config intltool icon-naming-utils))
     (home-page "https://mate-desktop.org/")
     (synopsis "The MATE desktop environment icon theme")
     (description
@@ -207,10 +206,8 @@ from Mint-X-F and Faenza-Fresh icon packs.")
         (base32 "051g2vq817g84yrqzf7hjcqr4xrghnw1rprjd6jf5mhhzmwcas6n"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("intltool" ,intltool)
-       ("gdk-pixbuf" ,gdk-pixbuf)       ; gdk-pixbuf+svg isn't needed
-       ("gtk" ,gtk+-2)))
+     (list pkg-config intltool gdk-pixbuf ; gdk-pixbuf+svg isn't needed
+           gtk+-2))
     (home-page "https://mate-desktop.org/")
     (synopsis
      "Official themes for the MATE desktop")
@@ -234,19 +231,16 @@ themes for both gtk+-2 and gtk+-3.")
         (base32 "1nd1dn8mm1z6x4r68a25q4vzys1a6fmbzc94ss1z1n1872pczs6i"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("intltool" ,intltool)
-       ("glib:bin" ,glib "bin")
-       ("gobject-introspection" ,gobject-introspection)
-       ("yelp-tools" ,yelp-tools)
-       ("gtk-doc" ,gtk-doc)))
+     (list pkg-config
+           intltool
+           `(,glib "bin")
+           gobject-introspection
+           yelp-tools
+           gtk-doc))
     (inputs
-     `(("gtk+" ,gtk+)
-       ("libxrandr" ,libxrandr)
-       ("iso-codes" ,iso-codes)
-       ("startup-notification" ,startup-notification)))
+     (list gtk+ libxrandr iso-codes startup-notification))
     (propagated-inputs
-     `(("dconf" ,dconf))) ; mate-desktop-2.0.pc
+     (list dconf)) ; mate-desktop-2.0.pc
     (home-page "https://mate-desktop.org/")
     (synopsis "Library with common API for various MATE modules")
     (description
@@ -277,21 +271,17 @@ desktop and the mate-about program.")
           (lambda* (#:key inputs #:allow-other-keys)
             (substitute* "data/check-timezones.sh"
               (("/usr/share/zoneinfo/zone.tab")
-               (string-append (assoc-ref inputs "tzdata")
-                              "/share/zoneinfo/zone.tab")))
-            #t)))))
+               (search-input-file inputs "/share/zoneinfo/zone.tab"))))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)
        ("dconf" ,dconf)
        ("glib:bin" ,glib "bin")))
     (inputs
-     `(("gtk+" ,gtk+)
-       ("tzdata" ,tzdata)))
+     (list gtk+ tzdata))
     (propagated-inputs
       ;; both of these are requires.private in mateweather.pc
-     `(("libsoup" ,libsoup)
-       ("libxml2" ,libxml2)))
+     (list libsoup-minimal-2 libxml2))
     (home-page "https://mate-desktop.org/")
     (synopsis "MATE library for weather information from the Internet")
     (description
@@ -312,21 +302,21 @@ the MATE desktop environment.")
         (base32 "0qmyhxmarwkxad8k1m9q1iwx70zhfp6zc2mh74nv26nj4gr3h3am"))))
     (build-system glib-or-gtk-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("intltool" ,intltool)
-       ("itstool" ,itstool)
-       ("gobject-introspection" ,gobject-introspection)
-       ("libxml2" ,libxml2)
-       ("yelp-tools" ,yelp-tools)))
+     (list pkg-config
+           intltool
+           itstool
+           gobject-introspection
+           libxml2
+           yelp-tools))
     (inputs
-     `(("dconf" ,dconf)
-       ("gtk+" ,gtk+)
-       ("libice" ,libice)
-       ("libsm" ,libsm)
-       ("libx11" ,libx11)
-       ("mate-desktop" ,mate-desktop)
-       ("pango" ,pango)
-       ("vte" ,vte)))
+     (list dconf
+           gtk+
+           libice
+           libsm
+           libx11
+           mate-desktop
+           pango
+           vte))
     (home-page "https://mate-desktop.org/")
     (synopsis "MATE Terminal Emulator")
     (description
@@ -369,17 +359,10 @@ configurations (profiles).")
                   (string-append "Exec=" out "/bin/mate-session\n")))
                #t))))))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("intltool" ,intltool)
-       ("libxcomposite" ,libxcomposite)
-       ("xtrans" ,xtrans)
-       ("gobject-introspection" ,gobject-introspection)))
+     (list pkg-config intltool libxcomposite xtrans
+           gobject-introspection))
     (inputs
-     `(("gtk+" ,gtk+)
-       ("dbus-glib" ,dbus-glib)
-       ("elogind" ,elogind)
-       ("libsm" ,libsm)
-       ("mate-desktop" ,mate-desktop)))
+     (list gtk+ dbus-glib elogind libsm mate-desktop))
     (home-page "https://mate-desktop.org/")
     (synopsis "Session manager for MATE")
     (description
@@ -400,28 +383,26 @@ configuration program to choose applications starting on login.")
         (base32 "0n1ywr3ir5p536s7azdbw2mh40ylqlpx3a74mjrivbms1rpjxyab"))))
     (build-system glib-or-gtk-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("intltool" ,intltool)
-       ("gobject-introspection" ,gobject-introspection)))
+     (list pkg-config intltool gobject-introspection))
     (inputs
-     `(("cairo" ,cairo)
-       ("dbus" ,dbus)
-       ("dbus-glib" ,dbus-glib)
-       ("dconf" ,dconf)
-       ("fontconfig" ,fontconfig)
-       ("gtk+" ,gtk+)
-       ("libcanberra" ,libcanberra)
-       ("libmatekbd" ,libmatekbd)
-       ("libmatemixer" ,libmatemixer)
-       ("libnotify" ,libnotify)
-       ("libx11" ,libx11)
-       ("libxext" ,libxext)
-       ("libxi" ,libxi)
-       ("libxklavier" ,libxklavier)
-       ("mate-desktop" ,mate-desktop)
-       ("nss" ,nss)
-       ("polkit" ,polkit)
-       ("startup-notification" ,startup-notification)))
+     (list cairo
+           dbus
+           dbus-glib
+           dconf
+           fontconfig
+           gtk+
+           libcanberra
+           libmatekbd
+           libmatemixer
+           libnotify
+           libx11
+           libxext
+           libxi
+           libxklavier
+           mate-desktop
+           nss
+           polkit
+           startup-notification))
     (home-page "https://mate-desktop.org/")
     (synopsis "Settings Daemon for MATE")
     (description
@@ -441,13 +422,9 @@ configuration program to choose applications starting on login.")
         (base32 "1n6rq7k66zvfd6sb7h92xihh021w9hysfa4yd1mzjcbb7c62ybqx"))))
     (build-system glib-or-gtk-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("intltool" ,intltool)
-       ("gobject-introspection" ,gobject-introspection)))
+     (list pkg-config intltool gobject-introspection))
     (inputs
-     `(("glib" ,glib)
-       ("pulseaudio" ,pulseaudio)
-       ("alsa-lib" ,alsa-lib)))
+     (list glib pulseaudio alsa-lib))
     (home-page "https://mate-desktop.org/")
     (synopsis "Mixer library for the MATE desktop")
     (description
@@ -469,16 +446,14 @@ sound systems.")
         (base32 "17mcxfkvl14p04id3n5kbhpjwjq00c8wmbyciyy2hm7kwdln6zx8"))))
     (build-system glib-or-gtk-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("intltool" ,intltool)
-       ("gobject-introspection" ,gobject-introspection)))
+     (list pkg-config intltool gobject-introspection))
     (inputs
-     `(("cairo" ,cairo)
-       ("gdk-pixbuf" ,gdk-pixbuf+svg)
-       ("glib" ,glib)
-       ("gtk+" ,gtk+)
-       ("libx11" ,libx11)
-       ("libxklavier" ,libxklavier)))
+     (list cairo
+           (librsvg-for-system)
+           glib
+           gtk+
+           libx11
+           libxklavier))
     (home-page "https://mate-desktop.org/")
     (synopsis "MATE keyboard configuration library")
     (description
@@ -512,9 +487,7 @@ MATE desktop environment.")
                  (string-append out "/lib/girepository-1.0/")))
               #t))))))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("intltool" ,intltool)
-       ("gobject-introspection" ,gobject-introspection)))
+     (list pkg-config intltool gobject-introspection))
     (inputs
      `(("glib" ,glib)
        ("python" ,python-2)))
@@ -539,36 +512,36 @@ assorted menu related utility programs.")
         (base32 "0h70i4x3bk017pgv4zn280682wm58vwdjm7kni91ni8rmblnnvyp"))))
     (build-system glib-or-gtk-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("intltool" ,intltool)
-       ("libxslt" ,libxslt)
-       ("yelp-tools" ,yelp-tools)
-       ("scrollkeeper" ,scrollkeeper)
-       ("gettext" ,gettext-minimal)
-       ("docbook-xml" ,docbook-xml)
-       ("gobject-introspection" ,gobject-introspection)))
+     (list pkg-config
+           intltool
+           libxslt
+           yelp-tools
+           scrollkeeper
+           gettext-minimal
+           docbook-xml
+           gobject-introspection))
     (inputs
-     `(("atk" ,atk)
-       ("dbus" ,dbus)
-       ("dbus-glib" ,dbus-glib)
-       ("glib" ,glib)
-       ("gucharmap" ,gucharmap)
-       ("gtk+" ,gtk+)
-       ("gtksourceview" ,gtksourceview-3)
-       ("libgtop" ,libgtop)
-       ("libmateweather" ,libmateweather)
-       ("libnotify" ,libnotify)
-       ("libx11" ,libx11)
-       ("libxml2" ,libxml2)
-       ("libwnck" ,libwnck)
-       ("mate-panel" ,mate-panel)
-       ("pango" ,pango)
-       ("polkit" ,polkit) ; either polkit or setuid
-       ("python" ,python-2)
-       ("upower" ,upower)
-       ("wireless-tools" ,wireless-tools)))
+     (list atk
+           dbus
+           dbus-glib
+           glib
+           gucharmap
+           gtk+
+           gtksourceview-3
+           libgtop
+           libmateweather
+           libnotify
+           libx11
+           libxml2
+           libwnck
+           mate-panel
+           pango
+           polkit ; either polkit or setuid
+           python-2
+           upower
+           wireless-tools))
     (propagated-inputs
-     `(("python-pygobject" ,python-pygobject)))
+     (list python-pygobject))
     (home-page "https://mate-desktop.org/")
     (synopsis "Various applets for the MATE Panel")
     (description
@@ -611,21 +584,18 @@ Interactive Weather Information Network (IWIN).
         (base32 "118i4w2i2g3hfgbfn3hjzjkfq8vjj6049r7my3vna9js23b7ab92"))))
     (build-system glib-or-gtk-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("intltool" ,intltool)
-       ("gettext" ,gettext-minimal)
-       ("gobject-introspection" ,gobject-introspection)))
+     (list pkg-config intltool gettext-minimal gobject-introspection))
     (inputs
-     `(("cairo" ,cairo)
-       ("gtk+" ,gtk+)
-       ("libcanberra" ,libcanberra)
-       ("libmatemixer" ,libmatemixer)
-       ("libxml2" ,libxml2)
-       ("mate-applets" ,mate-applets)
-       ("mate-desktop" ,mate-desktop)
-       ("mate-panel" ,mate-panel)
-       ("pango" ,pango)
-       ("startup-notification" ,startup-notification)))
+     (list cairo
+           gtk+
+           libcanberra
+           libmatemixer
+           libxml2
+           mate-applets
+           mate-desktop
+           mate-panel
+           pango
+           startup-notification))
     (home-page "https://mate-desktop.org/")
     (synopsis "Multimedia related programs for the MATE desktop")
     (description
@@ -672,32 +642,28 @@ mate-volume-control, a MATE volume control application and applet.")
                   (string-append out "/lib/girepository-1.0/")))
                #t))))))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("intltool" ,intltool)
-       ("itstool" ,itstool)
-       ("xtrans" ,xtrans)
-       ("gobject-introspection" ,gobject-introspection)))
+     (list pkg-config intltool itstool xtrans gobject-introspection))
     (inputs
-     `(("dconf" ,dconf)
-       ("cairo" ,cairo)
-       ("dbus-glib" ,dbus-glib)
-       ("gtk-layer-shell" ,gtk-layer-shell)
-       ("gtk+" ,gtk+)
-       ("libcanberra" ,libcanberra)
-       ("libice" ,libice)
-       ("libmateweather" ,libmateweather)
-       ("librsvg" ,librsvg)
-       ("libsm" ,libsm)
-       ("libx11" ,libx11)
-       ("libxau" ,libxau)
-       ("libxml2" ,libxml2)
-       ("libxrandr" ,libxrandr)
-       ("libwnck" ,libwnck)
-       ("mate-desktop" ,mate-desktop)
-       ("mate-menus" ,mate-menus)
-       ("pango" ,pango)
-       ("tzdata" ,tzdata)
-       ("wayland" ,wayland)))
+     (list dconf
+           cairo
+           dbus-glib
+           gtk-layer-shell
+           gtk+
+           libcanberra
+           libice
+           libmateweather
+           (librsvg-for-system)
+           libsm
+           libx11
+           libxau
+           libxml2
+           libxrandr
+           libwnck
+           mate-desktop
+           mate-menus
+           pango
+           tzdata
+           wayland))
     (home-page "https://mate-desktop.org/")
     (synopsis "Panel for MATE")
     (description
@@ -710,7 +676,7 @@ infamous 'Wanda the Fish'.")
 (define-public atril
   (package
     (name "atril")
-    (version "1.22.0")
+    (version "1.24.0")
     (source
      (origin
        (method url-fetch)
@@ -718,7 +684,7 @@ infamous 'Wanda the Fish'.")
                            name "-" version ".tar.xz"))
        (sha256
         (base32
-         "1xd49j4qwrlg2nh2zvspf91yk033dp8a58dy9azqg2yz4bcvywxb"))))
+         "0967gxw7h2qh2kpwl0jgv58hicz6aa92kr12mnykbpikad25s95y"))))
     (build-system glib-or-gtk-build-system)
     (arguments
      `(#:configure-flags (list (string-append "--with-openjpeg="
@@ -762,6 +728,7 @@ infamous 'Wanda the Fish'.")
        ("glib:bin" ,glib "bin")
        ("gobject-introspection" ,gobject-introspection)
        ("gtk-doc" ,gtk-doc)
+       ("texlive-bin" ,texlive-bin) ;synctex
        ("xmllint" ,libxml2)
        ("zlib" ,zlib)))
     (inputs
@@ -788,14 +755,14 @@ infamous 'Wanda the Fish'.")
        ("libgxps" ,libgxps)
        ("libjpeg" ,libjpeg-turbo)
        ("libxml2" ,libxml2)
-       ("dogtail" ,python2-dogtail)
+       ("dogtail" ,python-dogtail)
        ("shared-mime-info" ,shared-mime-info)
        ("gdk-pixbuf" ,gdk-pixbuf)
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
        ("libgnome-keyring" ,libgnome-keyring)
        ("libarchive" ,libarchive)
        ("marco" ,marco)
-       ("openjpeg" ,openjpeg-1)
+       ("openjpeg" ,openjpeg)
        ("pango" ,pango)
        ;;("texlive" ,texlive)
        ;; TODO:
@@ -842,15 +809,15 @@ infamous 'Wanda the Fish'.")
        ("xorg-server" ,xorg-server)
        ("gobject-introspection" ,gobject-introspection)))
     (inputs
-     `(("exempi" ,exempi)
-       ("gtk+" ,gtk+)
-       ("gvfs" ,gvfs)
-       ("libexif" ,libexif)
-       ("libnotify" ,libnotify)
-       ("libsm" ,libsm)
-       ("libxml2" ,libxml2)
-       ("mate-desktop" ,mate-desktop)
-       ("startup-notification" ,startup-notification)))
+     (list exempi
+           gtk+
+           gvfs
+           libexif
+           libnotify
+           libsm
+           libxml2
+           mate-desktop
+           startup-notification))
     (native-search-paths
      (list (search-path-specification
             (variable "CAJA_EXTENSIONDIR")
@@ -900,17 +867,17 @@ icons on the MATE desktop.  It works on local and remote file systems.")
        ("libxml2" ,libxml2)
        ("pkg-config" ,pkg-config)))
     (inputs
-     `(("attr" ,attr)
-       ("brasero" ,brasero)
-       ("caja" ,caja)
-       ("dbus" ,dbus)
-       ("dbus-glib" ,dbus-glib)
-       ("gajim" ,gajim) ;runtime only?
-       ("gtk+" ,gtk+)
-       ("graphicsmagick" ,graphicsmagick)
-       ("mate-desktop" ,mate-desktop)
-       ("pidgin" ,pidgin) ;runtime only?
-       ("startup-notification" ,startup-notification)))
+     (list attr
+           brasero
+           caja
+           dbus
+           dbus-glib
+           gajim ;runtime only?
+           gtk+
+           graphicsmagick
+           mate-desktop
+           pidgin ;runtime only?
+           startup-notification))
     (home-page "https://mate-desktop.org/")
     (synopsis "Extensions for the File manager Caja")
     (description
@@ -946,13 +913,13 @@ icons on the MATE desktop.  It works on local and remote file systems.")
                            (string-append out "/sbin")))
                         #t))))))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("intltool" ,intltool)
-       ("yelp-tools" ,yelp-tools)
-       ("desktop-file-utils" ,desktop-file-utils)
-       ("xorgproto" ,xorgproto)
-       ("xmodmap" ,xmodmap)
-       ("gobject-introspection" ,gobject-introspection)))
+     (list pkg-config
+           intltool
+           yelp-tools
+           desktop-file-utils
+           xorgproto
+           xmodmap
+           gobject-introspection))
     (inputs
      `(("atk" ,atk)
        ("cairo" ,cairo)
@@ -983,8 +950,7 @@ icons on the MATE desktop.  It works on local and remote file systems.")
        ("polkit" ,polkit)
        ("startup-notification" ,startup-notification)))
     (propagated-inputs
-     `(("gdk-pixbuf" ,gdk-pixbuf+svg) ; mate-slab.pc
-       ("librsvg" ,librsvg))) ; mate-slab.pc
+     (list (librsvg-for-system)))        ;mate-slab.pc
     (home-page "https://mate-desktop.org/")
     (synopsis "MATE Desktop configuration tool")
     (description
@@ -1005,32 +971,32 @@ of various aspects of your desktop.")
         (base32 "109b41pjrc1b4slw6sx1lakdhrc46x829vczzk4bz3j15kcszg54"))))
     (build-system glib-or-gtk-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("intltool" ,intltool)
-       ("itstool" ,itstool)
-       ("glib" ,glib)
-       ("gobject-introspection" ,gobject-introspection)
-       ("libxft" ,libxft)
-       ("libxml2" ,libxml2)
-       ("zenity" ,zenity)))
+     (list pkg-config
+           intltool
+           itstool
+           glib
+           gobject-introspection
+           libxft
+           libxml2
+           zenity))
     (inputs
-     `(("gtk+" ,gtk+)
-       ("libcanberra" ,libcanberra)
-       ("libgtop" ,libgtop)
-       ("libice" ,libice)
-       ("libsm" ,libsm)
-       ("libx11" ,libx11)
-       ("libxcomposite" ,libxcomposite)
-       ("libxcursor" ,libxcursor)
-       ("libxdamage" ,libxdamage)
-       ("libxext" ,libxext)
-       ("libxfixes" ,libxfixes)
-       ("libxinerama" ,libxinerama)
-       ("libxrandr" ,libxrandr)
-       ("libxrender" ,libxrender)
-       ("mate-desktop" ,mate-desktop)
-       ("pango" ,pango)
-       ("startup-notification" ,startup-notification)))
+     (list gtk+
+           libcanberra
+           libgtop
+           libice
+           libsm
+           libx11
+           libxcomposite
+           libxcursor
+           libxdamage
+           libxext
+           libxfixes
+           libxinerama
+           libxrandr
+           libxrender
+           mate-desktop
+           pango
+           startup-notification))
     (home-page "https://mate-desktop.org/")
     (synopsis "Window manager for the MATE desktop")
     (description
@@ -1071,7 +1037,7 @@ for use with MATE or as a standalone window manager.")
        ("yelp-tools" ,yelp-tools)
        ("yelp-xsl" ,yelp-xsl)))
     (inputs
-     `(("yelp" ,yelp)))
+     (list yelp))
     (home-page "https://mate-desktop.org/")
     (synopsis "User Documentation for Mate software")
     (description
@@ -1093,17 +1059,14 @@ sessions, panels, menus, file management, and preferences.")
         (base32 "0imdimq5d5rjq8mkjcrsd683a2bn9acmhc0lmvyw71y0040inbaw"))))
     (build-system glib-or-gtk-build-system)
     (native-inputs
-     `(("gettext" ,gettext-minimal)
-       ("intltool" ,intltool)
-       ("pkg-config" ,pkg-config)
-       ("yelp-tools" ,yelp-tools)))
+     (list gettext-minimal intltool pkg-config yelp-tools))
     (inputs
-     `(("atk" ,atk)
-       ("glib" ,glib)
-       ("gtk+" ,gtk+)
-       ("libxml2" ,libxml2)
-       ("libcanberra" ,libcanberra)
-       ("pango" ,pango)))
+     (list atk
+           glib
+           gtk+
+           libxml2
+           libcanberra
+           pango))
     (home-page "https://mate-desktop.org/")
     (synopsis "Calculator for MATE")
     (description
@@ -1124,7 +1087,7 @@ sessions, panels, menus, file management, and preferences.")
          "0b9yx68p9l867bqsl9z2g4wrs8p396ls673jgaliys5snmk8n8dn"))))
     (build-system glib-or-gtk-build-system)
     (native-inputs
-     `(("intltool" ,intltool)))
+     (list intltool))
     (home-page "https://mate-desktop.org/")
     (synopsis "Calculator for MATE")
     (description
@@ -1146,19 +1109,17 @@ can be used as backgrounds in the MATE Desktop environment.")
          "1bmk9gq5gcqkvfppa7i1hqfph8sajc3xs189s4ha97g0ifwd98a8"))))
     (build-system glib-or-gtk-build-system)
     (native-inputs
-     `(("gettext" ,gettext-minimal)
-       ("intltool" ,intltool)
-       ("pkg-config" ,pkg-config)))
+     (list gettext-minimal intltool pkg-config))
     (inputs
-     `(("cairo" ,cairo)
-       ("glib" ,glib)
-       ("gtk+" ,gtk+)
-       ("libfakekey" ,libfakekey)
-       ("libwnck" ,libwnck)
-       ("libxtst" ,libxtst)
-       ("libx11" ,libx11)
-       ("mate-panel" ,mate-panel)
-       ("xorgproto" ,xorgproto)))
+     (list cairo
+           glib
+           gtk+
+           libfakekey
+           libwnck
+           libxtst
+           libx11
+           mate-panel
+           xorgproto))
     (home-page "https://mate-desktop.org/")
     (synopsis "Tool for MATE on Netbooks")
     (description
@@ -1213,29 +1174,29 @@ Re-decorates windows on un-maximise.
        ("which" ,which)
        ("xorgproto" ,xorgproto)))
     (inputs
-     `(("cairo" ,cairo)
-       ("dconf" ,dconf)
-       ("dbus" ,dbus)
-       ("dbus-glib" ,dbus-glib)
-       ("glib" ,glib)
-       ("gtk+" ,gtk+)
-       ("gdk-pixbuf" ,gdk-pixbuf+svg)
-       ("libcanberra" ,libcanberra)
-       ("libglade" ,libglade)
-       ("libmatekbd" ,libmatekbd)
-       ("libnotify" ,libnotify)
-       ("libx11" ,libx11)
-       ("libxext" ,libxext)
-       ("libxklavier" ,libxklavier)
-       ("libxrandr" ,libxrandr)
-       ("libxrender" ,libxrender)
-       ("libxscrnsaver" ,libxscrnsaver)
-       ("libxxf86vm" ,libxxf86vm)
-       ("linux-pam" ,linux-pam)
-       ("mate-desktop" ,mate-desktop)
-       ("mate-menus" ,mate-menus)
-       ("pango" ,pango)
-       ("startup-notification" ,startup-notification)))
+     (list cairo
+           dconf
+           dbus
+           dbus-glib
+           glib
+           gtk+
+           (librsvg-for-system)
+           libcanberra
+           libglade
+           libmatekbd
+           libnotify
+           libx11
+           libxext
+           libxklavier
+           libxrandr
+           libxrender
+           libxscrnsaver
+           libxxf86vm
+           linux-pam
+           mate-desktop
+           mate-menus
+           pango
+           startup-notification))
     (home-page "https://mate-desktop.org/")
     (synopsis "Screensaver for MATE")
     (description
@@ -1257,29 +1218,29 @@ can be used as backgrounds in the MATE Desktop environment.")
          "1b16n1628gcsym5mph6lr9x5xm4rgkxsa8xwr2wlx8g2gw2775i1"))))
     (build-system glib-or-gtk-build-system)
     (native-inputs
-     `(("gettext" ,gettext-minimal)
-       ("gtk-doc" ,gtk-doc)
-       ("intltool" ,intltool)
-       ("libice" ,libice)
-       ("libsm" ,libsm)
-       ("pkg-config" ,pkg-config)
-       ("scrollkeeper" ,scrollkeeper)
-       ("xorgproto" ,xorgproto)
-       ("yelp-tools" ,yelp-tools)))
+     (list gettext-minimal
+           gtk-doc
+           intltool
+           libice
+           libsm
+           pkg-config
+           scrollkeeper
+           xorgproto
+           yelp-tools))
     (inputs
-     `(("atk" ,atk)
-       ("cairo" ,cairo)
-       ("glib" ,glib)
-       ("gtk+" ,gtk+)
-       ("gdk-pixbuf" ,gdk-pixbuf+svg)
-       ("libcanberra" ,libcanberra)
-       ("libgtop" ,libgtop)
-       ("libx11" ,libx11)
-       ("libxext" ,libxext)
-       ("mate-panel" ,mate-panel)
-       ("pango" ,pango)
-       ("udisks" ,udisks)
-       ("zlib" ,zlib)))
+     (list atk
+           cairo
+           glib
+           gtk+
+           (librsvg-for-system)
+           libcanberra
+           libgtop
+           libx11
+           libxext
+           mate-panel
+           pango
+           udisks
+           zlib))
     (home-page "https://mate-desktop.org/")
     (synopsis "Utilities for the MATE Desktop")
     (description
@@ -1309,41 +1270,40 @@ can be used as backgrounds in the MATE Desktop environment.")
         (base32 "0dralsc0dvs0l38cysdhx6kiaiqlb8qi6g9xz2cm6mjqyq3d3f9f"))))
     (build-system glib-or-gtk-build-system)
     (native-inputs
-     `(("gettext" ,gettext-minimal)
-       ("gtk-doc" ,gtk-doc)
-       ("gobject-introspection" ,gobject-introspection)
-       ("intltool" ,intltool)
-       ("pkg-config" ,pkg-config)
-       ("yelp-tools" ,yelp-tools)))
+     (list gettext-minimal
+           gtk-doc
+           gobject-introspection
+           intltool
+           pkg-config
+           yelp-tools))
     (inputs
-     `(("atk" ,atk)
-       ("cairo" ,cairo)
-       ("dconf" ,dconf)
-       ("dbus" ,dbus)
-       ("dbus-glib" ,dbus-glib)
-       ("exempi" ,exempi)
-       ("glib" ,glib)
-       ("gtk+" ,gtk+)
-       ("gdk-pixbuf" ,gdk-pixbuf+svg)
-       ("libcanberra" ,libcanberra)
-       ("libx11" ,libx11)
-       ("libxext" ,libxext)
-       ("libpeas" ,libpeas)
-       ("libxml2" ,libxml2)
-       ("libexif" ,libexif)
-       ("libjpeg" ,libjpeg-turbo)
-       ("librsvg" ,librsvg)
-       ("lcms" ,lcms)
-       ("mate-desktop" ,mate-desktop)
-       ("pango" ,pango)
-       ("shared-mime-info" ,shared-mime-info)
-       ("startup-notification" ,startup-notification)
-       ("zlib" ,zlib)))
+     (list atk
+           cairo
+           dconf
+           dbus
+           dbus-glib
+           exempi
+           glib
+           gtk+
+           libcanberra
+           libx11
+           libxext
+           libpeas
+           libxml2
+           libexif
+           libjpeg-turbo
+           (librsvg-for-system)
+           lcms
+           mate-desktop
+           pango
+           shared-mime-info
+           startup-notification
+           zlib))
     (home-page "https://mate-desktop.org/")
     (synopsis "Eye of MATE")
     (description
      "Eye of MATE is the Image viewer for the MATE Desktop.")
-    (license (list license:gpl2))))
+    (license license:gpl2)))
 
 (define-public engrampa
   (package
@@ -1380,17 +1340,17 @@ can be used as backgrounds in the MATE Desktop environment.")
        ("pkg-config" ,pkg-config)
        ("yelp-tools" ,yelp-tools)))
     (inputs
-     `(("caja" ,caja)
-       ("file" ,file)
-       ("glib" ,glib)
-       ("gtk+" ,gtk+)
-       ("gdk-pixbuf" ,gdk-pixbuf+svg)
-       ("json-glib" ,json-glib)
-       ("libcanberra" ,libcanberra)
-       ("libx11" ,libx11)
-       ("libsm" ,libsm)
-       ("packagekit" ,packagekit)
-       ("pango" ,pango)))
+     (list caja
+           file
+           glib
+           gtk+
+           (librsvg-for-system)
+           json-glib
+           libcanberra
+           libx11
+           libsm
+           packagekit
+           pango))
     (home-page "https://mate-desktop.org/")
     (synopsis "Archive Manager for MATE")
     (description
@@ -1422,24 +1382,24 @@ can be used as backgrounds in the MATE Desktop environment.")
        ("pkg-config" ,pkg-config)
        ("yelp-tools" ,yelp-tools)))
     (inputs
-     `(("atk" ,atk)
-       ("cairo" ,cairo)
-       ("enchant" ,enchant-1.6)
-       ("glib" ,glib)
-       ("gtk+" ,gtk+)
-       ("gtksourceview" ,gtksourceview-3)
-       ("gdk-pixbuf" ,gdk-pixbuf)
-       ("iso-codes" ,iso-codes)
-       ("libcanberra" ,libcanberra)
-       ("libx11" ,libx11)
-       ("libsm" ,libsm)
-       ("libpeas" ,libpeas)
-       ("libxml2" ,libxml2)
-       ("libice" ,libice)
-       ("packagekit" ,packagekit)
-       ("pango" ,pango)
-       ("python" ,python)
-       ("scrollkeeper" ,scrollkeeper)))
+     (list atk
+           cairo
+           enchant-1.6
+           glib
+           gtk+
+           gtksourceview-3
+           gdk-pixbuf
+           iso-codes
+           libcanberra
+           libx11
+           libsm
+           libpeas
+           libxml2
+           libice
+           packagekit
+           pango
+           python
+           scrollkeeper))
     (home-page "https://mate-desktop.org/")
     (synopsis "Text Editor for MATE")
     (description
@@ -1459,25 +1419,21 @@ can be used as backgrounds in the MATE Desktop environment.")
         (base32 "1i2r4lw6xsk972yp15g5hm8p8xx9pp6jmcvvzbdq80xyx3x898qz"))))
     (build-system glib-or-gtk-build-system)
     (native-inputs
-     `(("autoconf" ,autoconf)
-       ("gettext" ,gettext-minimal)
-       ("intltool" ,intltool)
-       ("pkg-config" ,pkg-config)
-       ("yelp-tools" ,yelp-tools)))
+     (list autoconf gettext-minimal intltool pkg-config yelp-tools))
     (inputs
-     `(("cairo" ,cairo)
-       ("glib" ,glib)
-       ("glibmm" ,glibmm)
-       ("gtkmm" ,gtkmm)
-       ("gtk+" ,gtk+)
-       ("gdk-pixbuf" ,gdk-pixbuf)
-       ("libsigc++" ,libsigc++)
-       ("libcanberra" ,libcanberra)
-       ("libxml2" ,libxml2)
-       ("libwnck" ,libwnck)
-       ("libgtop" ,libgtop)
-       ("librsvg" ,librsvg)
-       ("polkit" ,polkit)))
+     (list cairo
+           glib
+           glibmm
+           gtkmm-3
+           gtk+
+           gdk-pixbuf
+           libsigc++
+           libcanberra
+           libxml2
+           libwnck
+           libgtop
+           (librsvg-for-system)
+           polkit))
     (home-page "https://mate-desktop.org/")
     (synopsis "System Monitor for MATE")
     (description
@@ -1499,18 +1455,14 @@ MATE Desktop to monitor your system resources and usage.")
          "1450bqzlnvwy3xa98lj102j2cf7piqbxcd1cy2zp41rdl8ri3gvn"))))
     (build-system glib-or-gtk-build-system)
     (native-inputs
-     `(("gettext" ,gettext-minimal)
-       ("gtk-doc" ,gtk-doc)
-       ("intltool" ,intltool)
-       ("libtool" ,libtool)
-       ("pkg-config" ,pkg-config)))
+     (list gettext-minimal gtk-doc intltool libtool pkg-config))
     (inputs
-     `(("accountsservice" ,accountsservice)
-       ("glib" ,glib)
-       ("gobject-introspection" ,gobject-introspection)
-       ("gtk+" ,gtk+)
-       ("gdk-pixbuf" ,gdk-pixbuf)
-       ("polkit" ,polkit)))
+     (list accountsservice
+           glib
+           gobject-introspection
+           gtk+
+           gdk-pixbuf
+           polkit))
     (home-page "https://mate-desktop.org/")
     (synopsis "DBus specific service for MATE")
     (description
@@ -1535,7 +1487,7 @@ used to bring up authentication dialogs.")
             (union-build (assoc-ref %outputs "out")
                          directories)
             #t)))))
-    (native-inputs `(("desktop-file-utils" ,desktop-file-utils)))
+    (native-inputs (list desktop-file-utils))
     (inputs
      ;; TODO: Add more packages
      `(("at-spi2-core"              ,at-spi2-core)
@@ -1545,7 +1497,7 @@ used to bring up authentication dialogs.")
        ("dconf"                     ,dconf)
        ("engrampa"                  ,engrampa)
        ("eom"                       ,eom)
-       ("font-cantarell"            ,font-cantarell)
+       ("font-abattis-cantarell"            ,font-abattis-cantarell)
        ("glib-networking"           ,glib-networking)
        ("gnome-keyring"             ,gnome-keyring)
        ("gvfs"                      ,gvfs)
@@ -1582,7 +1534,7 @@ used to bring up authentication dialogs.")
        ("zenity"                    ,zenity)))
     (propagated-inputs
      ;; Default font that applications such as IceCat require.
-     `(("font-dejavu"             ,font-dejavu)))
+     (list font-dejavu))
     (synopsis "The MATE desktop environment")
     (home-page "https://mate-desktop.org/")
     (description