summary refs log tree commit diff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm22
1 files changed, 6 insertions, 16 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index c3a4edd1ea..88f64fdb66 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -923,12 +923,7 @@ icons on the MATE desktop.  It works on local and remote file systems.")
        ("intltool" ,intltool)
        ("yelp-tools" ,yelp-tools)
        ("desktop-file-utils" ,desktop-file-utils)
-       ("kbproto" ,kbproto)
-       ("randrproto" ,randrproto)
-       ("renderproto" ,renderproto)
-       ("scrnsaverproto" ,scrnsaverproto)
-       ("xextpro" ,xextproto)
-       ("xproto" ,xproto)
+       ("xorgproto" ,xorgproto)
        ("xmodmap" ,xmodmap)
        ("gobject-introspection" ,gobject-introspection)))
     (inputs
@@ -1142,7 +1137,7 @@ can be used as backgrounds in the MATE Desktop environment.")
        ("libxtst" ,libxtst)
        ("libx11" ,libx11)
        ("mate-panel" ,mate-panel)
-       ("xproto" ,xproto)))
+       ("xorgproto" ,xorgproto)))
     (home-page "https://mate-desktop.org/")
     (synopsis "Tool for MATE on Netbooks")
     (description
@@ -1194,15 +1189,10 @@ Re-decorates windows on un-maximise.
        ("autoconf" ,autoconf-wrapper)
        ("gettext" ,gettext-minimal)
        ("intltool" ,intltool)
-       ("kbproto" ,kbproto)
        ("mate-common" ,mate-common)
        ("pkg-config" ,pkg-config)
-       ("randrproto" ,randrproto)
-       ("renderproto" ,renderproto)
-       ("scrnsaverproto" ,scrnsaverproto)
        ("which" ,which)
-       ("xextpro" ,xextproto)
-       ("xproto" ,xproto)))
+       ("xorgproto" ,xorgproto)))
     (inputs
      `(("cairo" ,cairo)
        ("dconf" ,dconf)
@@ -1256,8 +1246,7 @@ can be used as backgrounds in the MATE Desktop environment.")
        ("libsm" ,libsm)
        ("pkg-config" ,pkg-config)
        ("scrollkeeper" ,scrollkeeper)
-       ("xextpro" ,xextproto)
-       ("xproto" ,xproto)
+       ("xorgproto" ,xorgproto)
        ("yelp-tools" ,yelp-tools)))
     (inputs
      `(("atk" ,atk)
@@ -1534,7 +1523,8 @@ used to bring up authentication dialogs.")
          (match %build-inputs
            (((names . directories) ...)
             (union-build (assoc-ref %outputs "out")
-                         directories))))))
+                         directories)
+            #t)))))
     (inputs
      ;; TODO: Add more packages
      `(("at-spi2-core"              ,at-spi2-core)