summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index cc9a9a40a8..5f2697e13c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2448,15 +2448,14 @@ Fresnel integrals, and similar related functions as well.")
              (string-append "INSTALL_INCLUDE="
                             (assoc-ref %outputs "out") "/include"))
        #:phases
-       (alist-cons-before
-        'install 'prepare-out
-        ;; README.txt states that the target directories must exist prior to
-        ;; running "make install".
-        (lambda _
-          (mkdir-p (string-append (assoc-ref %outputs "out") "/lib"))
-          (mkdir-p (string-append (assoc-ref %outputs "out") "/include")))
-        ;; no configure script
-        (alist-delete 'configure %standard-phases))))
+       (modify-phases %standard-phases
+         (delete 'configure)            ;no configure script
+         (add-before 'install 'prepare-out
+           ;; README.txt states that the target directories must exist prior to
+           ;; running "make install".
+           (lambda _
+             (mkdir-p (string-append (assoc-ref %outputs "out") "/lib"))
+             (mkdir-p (string-append (assoc-ref %outputs "out") "/include")))))))
     (inputs
      `(("tbb" ,tbb)
        ("lapack" ,lapack)))