summary refs log tree commit diff
path: root/gnu/packages/mingw.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mingw.scm')
-rw-r--r--gnu/packages/mingw.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/mingw.scm b/gnu/packages/mingw.scm
index 87a565059e..ae8bea1009 100644
--- a/gnu/packages/mingw.scm
+++ b/gnu/packages/mingw.scm
@@ -46,7 +46,7 @@ specified, recurse and return a mingw-w64 with support for winpthreads."
     (package
       (name (string-append "mingw-w64" "-" machine
                            (if with-winpthreads? "-winpthreads" "")))
-      (version "8.0.0")
+      (version "10.0.0")
       (source
        (origin
          (method url-fetch)
@@ -54,7 +54,7 @@ specified, recurse and return a mingw-w64 with support for winpthreads."
                "mirror://sourceforge/mingw-w64/mingw-w64/"
                "mingw-w64-release/mingw-w64-v" version ".tar.bz2"))
          (sha256
-          (base32 "0qjpb9rviasfshk337j5r32ncmrwml8sv6qnmb1lp4mkdbm41is4"))
+          (base32 "15089y4rlj6g1m2m3cm3awndw3rbzhznl7skd0vkmikjxl546sxs"))
          (patches
           (search-patches "mingw-w64-6.0.0-gcc.patch"
                           "mingw-w64-dlltool-temp-prefix.patch"
@@ -108,6 +108,7 @@ specified, recurse and return a mingw-w64 with support for winpthreads."
                               xlibc "/lib" ":"
                               xlibc "/" ,triplet "/lib"))))))))
          #:make-flags (list "DEFS=-DHAVE_CONFIG_H -D__MINGW_HAS_DXSDK=1")
+         #:parallel-build? #f ; parallel builds often fail with empty .a files
          #:tests? #f ; compiles and includes glibc headers
          #:strip-binaries? #f))
       (home-page "https://mingw-w64.org")
@@ -143,7 +144,7 @@ several new APIs such as DirectX and DDK, and 64-bit support.")
 (define-public mingw-w64-tools
   (package
     (name "mingw-w64-tools")
-    (version "8.0.0")
+    (version "10.0.0")
     (source
      (origin
        (method url-fetch)
@@ -151,7 +152,7 @@ several new APIs such as DirectX and DDK, and 64-bit support.")
              "mirror://sourceforge/mingw-w64/mingw-w64/"
              "mingw-w64-release/mingw-w64-v" version ".tar.bz2"))
        (sha256
-        (base32 "0qjpb9rviasfshk337j5r32ncmrwml8sv6qnmb1lp4mkdbm41is4"))))
+        (base32 "15089y4rlj6g1m2m3cm3awndw3rbzhznl7skd0vkmikjxl546sxs"))))
     (build-system gnu-build-system)
     (arguments
      `(#:modules ((guix build gnu-build-system)