summary refs log tree commit diff
path: root/gnu/packages/monitoring.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/monitoring.scm')
-rw-r--r--gnu/packages/monitoring.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index f6a1153548..aae39f19f9 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -2,9 +2,9 @@
 ;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
 ;;; Copyright © 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
-;;; Copyright © 2018, 2019 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2018, 2019, 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2020 Alex ter Weele <alex.ter.weele@gmail.com>
 ;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
 ;;;
@@ -158,16 +158,15 @@ etc. via a Web interface.  Features include:
 (define-public zabbix-agentd
   (package
     (name "zabbix-agentd")
-    (version "4.4.6")
+    (version "5.0.2")
     (source
      (origin
        (method url-fetch)
        (uri (string-append
-             "mirror://sourceforge/zabbix/ZABBIX%20Latest%20Stable/" version
-             "/zabbix-" version ".tar.gz"))
+             "https://cdn.zabbix.com/zabbix/sources/stable/"
+             (version-major+minor version) "/zabbix-" version ".tar.gz"))
        (sha256
-        (base32
-         "03mf4sklnw1x0ixp41vnibkz0794yi9jhws7ixld8jj2czk2ifr2"))))
+        (base32 "1cnns7ixqi7ank3cbvcs7d8rb5zh9qiqbmgivazr83jnz81qg46w"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags
@@ -201,7 +200,7 @@ solution (client-side agent)")
                         (front-end-conf (string-append php "/conf"))
                         (etc (string-append php "/etc")))
                    (mkdir-p php)
-                   (copy-recursively "frontends/php" php)
+                   (copy-recursively "ui" php)
                    ;; Make front-end write config to ‘/etc/zabbix’ directory.
                    (rename-file front-end-conf
                                 (string-append front-end-conf "-example"))
@@ -412,7 +411,7 @@ WSGI and the node exporter textfile collector.")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "https://github.com/prometheus/node_exporter.git")
+                    (url "https://github.com/prometheus/node_exporter")
                     (commit (string-append "v" version))))
               (file-name (git-file-name name version))
               (sha256
@@ -434,7 +433,7 @@ written in Go with pluggable metric collectors.")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                      (url "https://github.com/emcrisostomo/fswatch.git")
+                      (url "https://github.com/emcrisostomo/fswatch")
                       (commit version)))
               (file-name (git-file-name name version))
               (sha256