summary refs log tree commit diff
path: root/gnu/packages/mp3.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mp3.scm')
-rw-r--r--gnu/packages/mp3.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index 03e4485618..80e3b35469 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -212,7 +212,7 @@ whose primary goals are full compliance with the ID3v2 standard, portability
 across several platforms, and providing a powerful and feature-rich API with
 a highly stable and efficient implementation.")
    (license license:lgpl2.0+)
-   (home-page "http://id3lib.sourceforge.net/")))
+   (home-page "https://id3lib.sourceforge.net/")))
 
 (define-public taglib
   (package
@@ -377,7 +377,7 @@ automatic silence split, that can be used also to adjust cddb/cue splitpoints.
 
 This package contains the library.")
    (license license:gpl2+)
-   (home-page "http://mp3splt.sourceforge.net/mp3splt_page/home.php")))
+   (home-page "https://mp3splt.sourceforge.net/mp3splt_page/home.php")))
 
 (define-public mp3splt
   (package
@@ -404,12 +404,12 @@ automatic silence split, that can be used also to adjust cddb/cue splitpoints.
 
 This package contains the binary.")
    (license license:gpl2+)
-   (home-page "http://mp3splt.sourceforge.net/mp3splt_page/home.php")))
+   (home-page "https://mp3splt.sourceforge.net/mp3splt_page/home.php")))
 
 (define-public mpg123
   (package
     (name "mpg123")
-    (version "1.28.2")
+    (version "1.31.2")
     (source
      (origin
        (method url-fetch)
@@ -419,7 +419,7 @@ This package contains the binary.")
                    "https://www.mpg123.org/download/mpg123-"
                    version ".tar.bz2")))
        (sha256
-        (base32 "006v44nz4nkpgvxz1k2vbbrfpa2m47hyydscs0wf3iysiyvd9vvy"))))
+        (base32 "1pn777l9m7qbsx4v93gnav8bf6yi3skzdz8x81mkpx1ibs824zxi"))))
     (build-system gnu-build-system)
     (arguments '(#:configure-flags '("--with-default-audio=pulse")))
     (native-inputs
@@ -456,7 +456,7 @@ command-line tool as well as a C library, libmpg123.")
        ("libmad" ,libmad)
        ("libid3tag" ,libid3tag)
        ("libao" ,ao)))
-    (home-page "http://mpg321.sourceforge.net/")
+    (home-page "https://mpg321.sourceforge.net/")
     (synopsis "Command-line MP3 player")
     (description "Mpg321 is a command-line mp3 player.  mpg321 is used for
 frontends, as an mp3 player and as an mp3 to wave file decoder (primarily for
@@ -497,7 +497,7 @@ use with CD-recording software).")
                            Libs: -L${libdir} -lmp3lame~@
                            Cflags: -I${includedir}~%"
                            out ,version)))))))))
-    (home-page "http://lame.sourceforge.net/")
+    (home-page "https://lame.sourceforge.net/")
     (synopsis "MPEG Audio Layer III (MP3) encoder")
     (description "LAME is a high quality MPEG Audio Layer III (MP3) encoder.")
     (license license:lgpl2.0)))