summary refs log tree commit diff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm36
1 files changed, 29 insertions, 7 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index a10fbfed92..95253687cd 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -11,6 +11,7 @@
 ;;; Copyright © 2016, 2017 ng0 <ng0@libertad.pw>
 ;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2016 Benz Schenk <benz.schenk@uzh.ch>
+;;; Copyright © 2016, 2017 Pjotr Prins <pjotr.guix@thebird.nl>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -80,7 +81,7 @@
     (description "GNU MAC Changer is a utility for viewing and changing MAC
 addresses of networking devices.  New addresses may be set explicitly or
 randomly.  They can include MAC addresses of the same or other hardware vendors
-or, more generally, MAC addresses of the same category of hardware.") 
+or, more generally, MAC addresses of the same category of hardware.")
     (license license:gpl2+)))
 
 (define-public miredo
@@ -430,7 +431,7 @@ and up to 1 Mbit/s downstream.")
 (define-public whois
   (package
     (name "whois")
-    (version "5.2.14")
+    (version "5.2.15")
     (source
      (origin
        (method url-fetch)
@@ -438,7 +439,7 @@ and up to 1 Mbit/s downstream.")
                            name "_" version ".tar.xz"))
        (sha256
         (base32
-         "1lmh7168yby1ma8r1svgvmv9hbgjyniy9c64r6lby3zdmd0sy7d4"))))
+         "123ingf699javzh8qm6ny10nl28zbjzasa4k5pcn0qzw1dlnnnks"))))
     (build-system gnu-build-system)
     ;; TODO: unbundle mkpasswd binary + its po files.
     (arguments
@@ -469,7 +470,7 @@ which can be used to encrypt a password with @code{crypt(3)}.")
 (define-public wireshark
   (package
     (name "wireshark")
-    (version "2.2.4")
+    (version "2.2.5")
     (synopsis "Network traffic analyzer")
     (source
      (origin
@@ -478,7 +479,7 @@ which can be used to encrypt a password with @code{crypt(3)}.")
                            version ".tar.bz2"))
        (sha256
         (base32
-         "049r5962yrajhhz9r4dsnx403dab50d6091y2mw298ymxqszp9s2"))))
+         "1j4sc3pmy8l6k41007spglcqiabjlzc7f85pn3jmjr9ksv9qipbm"))))
     (build-system glib-or-gtk-build-system)
     (inputs `(("bison" ,bison)
               ("c-ares" ,c-ares)
@@ -1006,14 +1007,14 @@ that block port 22.")
 (define-public iperf
   (package
     (name "iperf")
-    (version "3.1.3")
+    (version "3.1.7")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://downloads.es.net/pub/iperf"
                                   "/iperf-" version ".tar.gz"))
               (sha256
                 (base32
-                 "1gwmhm29zlp5grrpglmqj7vgx19s6xy33hk6hpbn8jnpn5lxpn30"))))
+                 "0kvk8d0a3dcxc8fisyprbn01y8akxj4sx8ld5dh508p9dx077vx4"))))
     (build-system gnu-build-system)
     (synopsis "TCP, UDP and SCTP bandwidth measurement tool")
     (description
@@ -1119,3 +1120,24 @@ IPFIX, RSPAN, CLI, LACP, 802.1ag).")
            license:gpl2                 ; datapath
            license:bsd-2 license:bsd-3
            license:asl2.0))))           ; all other
+
+(define-public speedtest-cli
+  (package
+    (name "speedtest-cli")
+    (version "1.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/sivel/speedtest-cli/archive/v" version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1ir9fqwr7cl9kfq7dgh9vkydkwf59wsx0cwbzbffw8i313xhzxa1"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/sivel/speedtest-cli")
+    (synopsis "Internet bandwidth tester")
+    (description
+     "Command line interface for testing internet bandwidth using
+speedtest.net.")
+    (license license:asl2.0)))