summary refs log tree commit diff
path: root/gnu/packages/ninja.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ninja.scm')
-rw-r--r--gnu/packages/ninja.scm17
1 files changed, 3 insertions, 14 deletions
diff --git a/gnu/packages/ninja.scm b/gnu/packages/ninja.scm
index b55dd37e78..a0eb109bbb 100644
--- a/gnu/packages/ninja.scm
+++ b/gnu/packages/ninja.scm
@@ -23,7 +23,6 @@
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
-  #:use-module (gnu packages base)
   #:use-module (gnu packages python))
 
 (define-public ninja
@@ -38,23 +37,13 @@
               (sha256
                (base32
                 "1h3yfwcfl61v493vna6jia2fizh8rpig7qw2504cvkr6gid3p5bw"))
-              ;; XXX Ninja's build system doesn't cope well with zeroed
-              ;; time stamps in the source tree, so we must avoid using
-              ;; 'patch-and-repack'.
-              #; (patches (list (search-patch "ninja-tests.patch")))))
+              (patches (map search-patch
+                            '("ninja-zero-mtime.patch" "ninja-tests.patch")))))
     (build-system gnu-build-system)
-    (native-inputs `(("python" ,python-2)
-                     ("patch" ,patch)
-                     ("ninja-tests.patch" ,(search-patch "ninja-tests.patch"))))
+    (native-inputs `(("python" ,python-2)))
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (add-after
-          'unpack 'apply-ninja-tests.patch
-          ;; XXX Apply the patch here to avoid 'patch-and-repack'.  See above.
-          (lambda* (#:key inputs #:allow-other-keys)
-            (zero? (system* "patch" "--force" "-p1" "-i"
-                            (assoc-ref inputs "ninja-tests.patch")))))
          (replace
           'configure
           (lambda _