summary refs log tree commit diff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 45791487af..76874b12d0 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1175,3 +1175,25 @@ Parsers are used to take raw binary data and transform them into usable
 messages.  This package provides @code{Ready}, a parser that waits for a
 specified sequence of ``ready'' bytes before emitting a ready event and
 emitting data events.")))
+
+(define-public node-serialport-parser-inter-byte-timeout
+  (package
+    (inherit node-serialport-binding-abstract)
+    (name "node-serialport-parser-inter-byte-timeout")
+    (version "9.2.4")
+    (inputs `())
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'chdir
+           (lambda args
+             (chdir "packages/parser-inter-byte-timeout"))))
+       #:tests? #f))
+    (synopsis "Node SerialPort parser to detect pauses in data")
+    (description "Node SerialPort is a modular suite of Node.js packages for
+accessing serial ports.  The Guix package @code{node-serialport} provides the
+recommended high-level interface.
+
+Parsers are used to take raw binary data and transform them into usable
+messages.  This package provides @code{InterByteTimeout}, a parser that emits
+data if there is a pause between packets for the specified amount of time.")))