summary refs log tree commit diff
path: root/gnu/packages/nss.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/nss.scm')
-rw-r--r--gnu/packages/nss.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 0d18592be4..8563eefc0a 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -29,6 +29,7 @@
   #:use-module (guix gexp)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system mozilla)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages)
   #:use-module (gnu packages bash)
@@ -49,7 +50,7 @@
               (sha256
                (base32
                 "177rxcf3lglabs7sgwcvf72ww4v56qa71lc495wl13sxs4f03vxy"))))
-    (build-system gnu-build-system)
+    (build-system mozilla-build-system)
     (inputs
      (list perl                         ;for 'compile-et.pl'
            bash-minimal))               ;for 'nspr-config'
@@ -69,16 +70,7 @@
       #~(list "--disable-static"
               "--enable-64bit"
               (string-append "LDFLAGS=-Wl,-rpath="
-                             (assoc-ref %outputs "out") "/lib")
-              ;; Mozilla deviates from Autotools conventions
-              ;; due to historical reasons.  Adjust to Mozilla conventions,
-              ;; otherwise the Makefile will try to use TARGET-gcc
-              ;; as a ‘native’ compiler.
-              #$@(if (%current-target-system)
-                     #~((string-append "--host="
-                                       #$(nix-system->gnu-triplet (%current-system)))
-                        (string-append "--target=" #$(%current-target-system)))
-                     #~()))
+                             (assoc-ref %outputs "out") "/lib"))
       ;; Use fixed timestamps for reproducibility.
       #:make-flags #~'("SH_DATE='1970-01-01 00:00:01'"
                        ;; This is epoch 1 in microseconds.